Upgrade IP16- Required Icon Is Not Showed On The Attribute But Only On The Product (Doc ID 2272651.1)

Last updated on JUNE 25, 2017

Applies to:

Siebel CRM - Version 16.7 [IP2016] and later
Information in this document applies to any platform.

Symptoms

On :  16.7 [IP2016] version, Order Management

ACTUAL BEHAVIOR  
---------------
Attributes that are mentioned as required are not shown as required when the Product eConfigurator is opened from Orders. But the same is working correctly when we open it from Product Definitions >> Versions >> Validate.

EXPECTED BEHAVIOR
-----------------------
Attributes that are mentioned as required should be shown as required when the Product eConfigurator is opened from Orders or from Product Definitions >> Versions >> Validate.

STEPS
-----------------------
1. Import the product attached in the bug.
2. Click on Validate button and click on Customize for first Prod "CPE SME" and then again click on Customize for the second product "Apparato connettivita" and click on customize.
3. List of attributes are shown
4. Notice that Attributes "Tipo apparato" and "Numero Porte" are required attributes.
5. These are shown as Required correctly.
6. Repeat the steps 2,3,4 by adding Product "CPE Dati" to a order.
7. The required attributes are not shown as required and then required red bell is shown only after I select a value from "Numero Porte".

Please view the recording for more details.

BUSINESS IMPACT
-----------------------
The issue has the following business impact:
Due to this issue, configurator is unusable because the required icon is not present: the user does not know the required attribute to populate.

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms