My Oracle Support Banner

Upgrade IP16- Required Icon Is Not Showed On The Attribute But Only On The Product (Doc ID 2272651.1)

Last updated on FEBRUARY 02, 2019

Applies to:

Siebel CRM - Version 16.7 [IP2016] and later
Information in this document applies to any platform.

Symptoms

On :  16.7 [IP2016] version, Order Management

ACTUAL BEHAVIOR  
---------------

Attributes that are configured as required is not marked/shown with a red color (indicates that are required) in Product eConfigurator when launched from customize button from Orders.


EXPECTED BEHAVIOR
-----------------------

Required Attributes will show in Product eConfigurator launched from Orders upon click on Customize button or from Product Definitions >> Versions >> Validate. 


STEPS
-----------------------
1. Import the product attached in the bug.
2. Click on Validate button and click on Customize for first Prod "Test SME" and then again click on Customize for the second product "Test connect" and click on customize.
3. List of attributes are shown
4. Notice that Attributes "Test Attribute" and "Test Number" are required attributes.
5. These are shown as Required correctly.
6. Repeat the steps 2,3,4 by adding Product "Test Data" to a order.
7. The required attributes are not shown as required and then required red bell is shown only after I select a value from "Test Number".


BUSINESS IMPACT
-----------------------
The issue has the following business impact:
Due to this issue, configurator is unusable because the required icon is not present and the user does not know which all required attributes to be populate.

Changes

 

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Changes
Cause
Solution
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.