Attribute Field Value In eConfigurator Are Not Always Corrected

(Doc ID 2322750.1)

Last updated on OCTOBER 30, 2017

Applies to:

Siebel CRM - Version 8.1.1.11.16 [IP2013] and later
Information in this document applies to any platform.

Symptoms

On : 8.1.1.11.16 [IP2013] version, Order Management

ACTUAL BEHAVIOR
---------------
Values for product attribute field (Data Type: Number, Domain Type: FreeForm) are not always corrected and no error are returned.
When user types phrase ended or started with letters, ex. "111aa" or "aa111" - eConfigurator does not show error, it only cuts letters from phrase. Then saved value is correct, also after switching tabs in eConf value in this field is showed correctly (for our example: "111"), but without switching tabs incorrect value is not corrected and error does not appear.

STEPS
-----------------------
The issue can be reproduced at will with the following steps:
1. Create two attributes field to fill (both: Number, FreeForm)
2. Create a custom product and add the class which contains the attributes. 
3. Add product to a quote
4. Click Customize to invoke the eConfigurator
5. Type "111aa" on first attribute value field
6. Click on second field and type also "111aa"
7. Click again on first field

Output: value of second field is corrected "111", but value of first field is still incorrect "111aa"

After steps 5-7 and switching tabs - values are displayed correctly (only numbers)
After steps 5-7 and clicking "Done" button - values are saved correctly (only numbers)

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms