My Oracle Support Banner

Siebel To OBIEE Integration SSO Not Working (Doc ID 2603686.1)

Last updated on MARCH 26, 2021

Applies to:

Siebel Marketing - Version 15.18 [IP2015] and later
Information in this document applies to any platform.

Symptoms

After migrating to OBIEE 12, when navigating to the Segments View from Siebel, the Login Page is displayed.

It is expected that it logs in to OBIEE automatically using the "Siebel Login" Id/password.

The following steps were taken to configure the Siebel/OBIEE Integration:

1. Set the userid and password for: Analytics Web, Default Analytics Web Server, Default KPI Analytics Server.

2. Configuration of the Outbound Web Services: SAWSessionServiceSoap, WebCatalogServiceSoap and JobManagementServiceSoap with the correct URL;

3. Define the NQHOST variable in Siebel Administration - Integration > Symbolic URL Administration

4. Configure Authentication thru Init Blocks - Authentication - Authorization. These Init Blocks connect to the corporate LDAP to validate the user and then the Authorization (from a Siebel table which have the responsibilities) to get the group/roles to which the user belongs.

5. All the users that we set up are able to login to OBIEE with the correct group/roles and in this part all seems to work fine

6. Logon to Siebel and navigate to Segments View

7. OBIEE embedded Login Page is displayed which is not expected.

8. Manually enter the User/Pass - User is logged in as expected.

9. Trying to use URL: http://<OBIEE>:<Port#>/analytics/saw.dll?Logon&NQUser=<admin user>&NQPassword=<passwd>&Impersonate=<impersonator user> also fails and the login page is displayed.


Changes

 

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Changes
Cause
Solution
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.