My Oracle Support Banner

Field User Property Updates/Changes Are Not Reflected with Inspect or Deliver Workspace Unless Server Is Restarted (Doc ID 2644288.1)

Last updated on AUGUST 27, 2020

Applies to:

Siebel Call Center - Version 20.1 and later
Information in this document applies to any platform.

Symptoms

Changes to Field User Properties are not applied/reflected in the application with Inspect or Deliver Workspace, unless the server is restarted.

Steps

  1. Login to Siebel Tools.
  2. Create/open a developer workspace.
  3. Go to [Business Component] object list and select 'Account'.
  4. Go to [Business Component]->[Field] and select 'Location'.
  5. Go to [Business Component]->[Field]->[Field User Prop] and create a record as follows:
        Name: Required
        Value: IIf ([Name] = 'Test Account','Y','N')


Scenario 1:

  1. Login to Siebel Application and go to [Accounts]->[Accounts List] view.
  2. Create a new record that has 'Test Account' for the Name field.
  3. Test to make sure the Location field can be null.
  4. Click Cube icon to go to Workspace Dashboard view.
  5. Open the workspace and click Inspect.
  6. Go to the Account List View and test to see if the 'Field User Prop' works.
        => It doesn't work !!

  7. Restart Siebel Server and login to Siebel Application again. (Don't go to the Account List view)
  8. Go to Workspace Dashboard and inspect the workspace.
  9. Go to the Account List View and test see if the 'Field User Prop' works.
        => It works !!

  10. Re-login to Siebel Application.
  11. Go to the Account List View and test to see if the 'Field User Prop' works.
        => It still works !! (it is NOT supposed to work)

  12. Restart Siebel Server and login to Siebel Application.
  13. Go to the Account List View and test again.
     => the Field User Prop doesn't work.


Scenario 2:

  1. In Siebel Tools, deliver the workspace to MAIN.
  2. Re-login to Siebel Application.
  3. Go to the Account List View and test see if the 'Field User Prop' works.
    => It doesn't work!! (it is supposed to work)

  4. Restart Siebel Server and login to Siebel Application.
  5. Go to the Account List View and test see if the 'Field User Prop' works.
        => It works !!

Changes

 

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Changes
Cause
Solution
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.