My Oracle Support Banner

On Solaris OS EAI HTTP Transport Failing When Arabic Characters Are Present In URL (Doc ID 2672732.1)

Last updated on MAY 21, 2020

Applies to:

Siebel CRM - Version 19.10 and later
Information in this document applies to any platform.

Symptoms

ERROR
-----------------------

EAITransport EAITransportDebug 4 00000fea5e284bbf:0 2020-01-23 09:40:44 *** HTTP response Body from Data Send request:
EAITransportPerf EAITransportPerf 5 00000fea5e284bbf:0 2020-01-23 09:40:44 HTTP Open Request Time = 1 millis
EAITransportPerf EAITransportPerf 5 00000fea5e284bbf:0 2020-01-23 09:40:44 HTTP Send Time = 271 millis
EAITransportPerf EAITransportPerf 5 00000fea5e284bbf:0 2020-01-23 09:40:44 HTTP Read Header Time = 0 millis
EAITransportPerf EAITransportPerf 5 00000fea5e284bbf:0 2020-01-23 09:40:44 HTTP Read Body Time = 0 millis
ObjMgrLog Error 1 00000fea5e284bbf:0 2020-01-23 09:40:44 (httptransport.cpp (1795)) SBL-EAI-04117: HTTP Request error during 'Submitting Data SendHTTP request': 'Status code - 500'
ObjMgrLog Error 1 00000fea5e284bbf:0 2020-01-23 09:40:44 (httptransport.cpp (1123)) SBL-EAI-04117: HTTP Request error during 'Submitting Data Send HTTP request': 'Status code - 500'


STEPS
-----------------------
The issue can be reproduced at will with the following steps:
1.  Login to Application
2.  Navigate to Administration Business Service --> Simulator
3.  Select the Business Service as EAI HTTP Transport and Method as SendReceive
4.  Properties as:

HTTPRequestURLTemplate =
https://www.google.com/search?ei=InpCXtPINc6O4-EPx9KXmAI&q=speedtest&oq=speedtest&gs_l=psy-ab.3..0i67j0l8j0i10.137319.139037..139435...0.3..0.108.905.3j6...0....1..gws-wiz.......0i71j0i131.ByJla_E7I3Q&ved=0ahUKEwjT4ZrhncnnAhVOxzgGHUfpBSMQ4dUDCAo&uact=5

HTTPRequestMethod = GET

Submit the request

We get the response.

Now changed the URL to
https://www.google.com/search?ei=InpCXtPINc6O4-EPx9KXmAI&q=البحرين&oq=البحرين&gs_l=psy-ab.3..0i67j0l8j0i10.137319.139037..139435...0.3..0.108.905.3j6......0....1..gws-wiz.......0i71j0i131.ByJla_E7I3Q&ved=0ahUKEwjT4ZrhncnnAhVOxzgGHUfpBSMQ4dUDCAo&uact=5

Getting 400 error.

This is seen only on Solaris OS and not on Windows OS. On Windows OS we getthe response.


Changes

 

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Changes
Cause
Solution
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.