My Oracle Support Banner

ESD - How To Change The Java Version ESD Uses (Doc ID 2799857.1)

Last updated on SEPTEMBER 09, 2021

Applies to:

Siebel Marketing - Version 21.4 and later
Information in this document applies to any platform.

Goal

Requirement was to installing EMS 21.4 on Windows 2019 using an old JRE version and then to update ESD to the latest JRE when this is delivered

As this new version was unable to be installed via the current JRE, the following workaround was suggested:

1. Install 2 JRE Versions: latest [jre1.8.0.251] and [jre1.8.0.111].
2. Open a Command prompt with Admin role.
3. Run below commands for all components from .exe location [esd/ctd/bhd/wsd].
 
  .\esd-21.8-install.exe LAX_VM "C:\Program Files\Java\jre1.8.0_111\bin\java.exe"
  .\ctd-21.8-install.exe LAX_VM "C:\Program Files\Java\jre1.8.0_111\bin\java.exe"
  .\bhd-21.8-install.exe LAX_VM "C:\Program Files\Java\jre1.8.0_111\bin\java.exe"
  .\wsd-21.8-install.exe LAX_VM "C:\Program Files\Java\jre1.8.0_111\bin\java.exe"

4. Once the Installer is up for a particular component, select the latest jre update version[jre1.8.0.251].
5. Finish the installation.

At this point, the old JRE has been added to the registry, so if the old JRE version is removed ESD fails to start.

The question was how to switch the JRE version to keep up with the most current secure version of JRE
 

Solution

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Goal
Solution


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.