Siebel Gateway Configuration fails with"HTTP Status 500 – Internal Server Error" in Containerized Environment
(Doc ID 3023833.1)
Last updated on JULY 01, 2024
Applies to:
Siebel CRM - Version 24.3 and laterInformation in this document applies to any platform.
Symptoms
Siebel Gateway configuration fails with error "HTTP Status 500 – Internal Server Error" in Container environment
Error in console:
<!doctype html><html lang="en"><head><title>HTTP Status 500 – Internal Server Error</title><style type="text/css">body {font-family:Tahoma,Arial,sans-serif;} h1, h2, h3, b {color:white;background-color:#525D76;} h1 {font-size:22px;} h2 {font-size:16px;} h3 {font-size:14px;} p {font-size:12px;} a {color}
<!doctype html><html lang="en"><head><title>HTTP Status 500 – Internal Server Error</title><style type="text/css">body {font-family:Tahoma,Arial,sans-serif;} h1, h2, h3, b {color:white;background-color:#525D76;} h1 {font-size:22px;} h2 {font-size:16px;} h3 {font-size:14px;} p {font-size:12px;} a {color}
The issue can be reproduced at will with the following steps:
- Installed siebel 24.3 in Containerized Environment as documented in : Deploying Siebel CRM Containers
- When configuring the siebel gateway to identify the gateway, it fails with error.
Cause
The cause of the issue is password used in script for installing SAI (Siebel Application Interface) . The password provided during install is from DEV environment but it was validated against the different password in this test environment during configuration.
Solution
The issue can be resolved by following steps:
1. Edit the install script to install SAI and update the password to the test environment's password instead of Development environment's password.
2. Deploy and Launch the Siebel Containers using the following command