EIM Imported employees not shown in User Interface and S_CONTACT.BU_ID being set to 'No Match Row id'

(Doc ID 519952.1)

Last updated on JUNE 04, 2017

Applies to:

Siebel Enterprise Integration Manager - Version 7.5.2.100 [15252] and later
Oracle Solaris on SPARC (64-bit)
Product Release: V7 (Enterprise)
Version: 7.5.2.100 [15252]
Database: Oracle 9.0.1.3
Application Server OS: Sun Solaris 5.6
Database Server OS: Sun Solaris 5.6




Symptoms

We are loading employees into ERM.

We changed the default Organization to CISCO.
The first problem we have is that the organization fields in the employee administration view>employees does not show in the app. every thing else get loaded in the following sequence
1-Employee
2-Position with pr_emp_id(using miscsql)
3-employee with pr_held_postn_id, pr_resp_id(using miscsql)
everything get set properly except that particular field.

When we query the s_contact table it shows "No Match Row id' in the Bu_ID column. When we look at the eim_employee table con_bi get resolved properly '0-R9NH'(con_bu being set to CISCO.
The division is set to CISCO but the organization is empty.
This behavior is particularly strange because we use the same exact mapping than in the score project (7.5.1) and the Organization was not a problem.

In another hand
We want the Employees to show in the following views:
All Employees
All Employees across Organizations
All Contacts
All Contacts across Organizations

The question is what flag/ tables should be populated for that to happen:


Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms