Problems to Define The Parameters for a Preventive Maintenance Engine Component Request? (Doc ID 538369.1)

Last updated on JANUARY 27, 2017

Applies to:

Siebel Field Service - Version 7.5.2.216 [16084] and later
All Platforms
Product Release: V7 (Enterprise)
Version: 7.5.2.216 [16084]
Database: Oracle 9.2.0.2
Application Server OS: Microsoft Windows 2000 Server SP 3
Database Server OS: IBM AIX 4.3.3

***Checked for relevance on 29-Oct-2011***
***Checked for relevance on 06-Jan-2014***

This document was previously published as Siebel SR 38-1176869651.


Symptoms

SBL-UNU-07000, SBL-DAT-00501, SBL-OMS-00203, SBL-PME-00018

We are trying to figure out how the Preventive Maintenance Engine is executed from the Component Request View.

We performed the following actions to set up the PM Plan as per example from Siebel Bookshelf.

  1. Created a PM Plan in the Preventive Maintenance Screen and associated a Time Interval Trigger with the following values: Interval 1, Valid Start 0, Valid End 7
  2. Created a new dummy Product in the Products Screen.
  3. Created a new asset in the Asset Screen.
  4. Added the dummy product in the Preventive Maintenance Products View. Associated the new asset to the product.
  5. Created a new SR Template and associated an Activity Template to it.
  6. In the Preventive Maintenance Actions View under the SR Templates added the new SR Template.
  7. We set the Preventive Maintenance Flag (TRUE) in the User Preferences View.
  8. Proceeded to the Server Administration Screen > Enterprise Operations > Components Request View. Created a new Component Request for Preventive Maintenance and added the following Component Request Parameters:
ParameterValue
Asset ID 1-2CD9 (Row Id for the Asset)
End Date 2004-01-31
Mode Id
Plan ID 1-2CD3 (Row Id for the PM Plan)
Sub-mode Assets&Plans

=> After submitting the request, the Status of Job remains in Queue and never completes.

Are these the correct parameters we should be setting? Our objective is to be able to run the PM Engine using Component Request or Repeated Component Requests.

Like wise we tried running PM Engine from the Asset Preventive Maintenance View. After pressing RUN PM nothing ever appears in the History and it appears to be in queue.

We need help in understanding how to go about running the PM engine. Bookshelf is not clear on how to set these parameters.

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms