Connection to a serial port hangs on Solaris[TM] 8 and Solaris[TM] 9 (Doc ID 1008978.1)

Last updated on JULY 29, 2016

Applies to:

Solaris Operating System - Version 8.0 to 9 9/05 HW U9 [Release 8.0 to 9.0]
All Platforms
***Checked for relevance on 12-MAY-2014***

Symptoms

While attempting a serial port connection, the login prompt doesn't
display. This may happen either telneting to a terminal concentrator or
using tip. If a terminal concentrator is used, the telnet connection will
be established but the login prompt won't be displayed. Solaris[TM] will appear
as running normally to the users.

To verify the problem use sacadm, pmadm and truss commands;

1) /dev/console line isn't present within running processes although
port monitors may appear to be ok.
# /usr/sbin/sacadm -l
PMTAG          PMTYPE         FLGS RCNT STATUS     COMMAND
zsmon          ttymon         -    0    ENABLED    /usr/lib/saf/ttymon #
# /usr/sbin/pmadm -l
PMTAG          PMTYPE         SVCTAG         FLGS ID       <PMSPECIFIC>
zsmon          ttymon         ttya           u    root     /dev/term/a I -
/usr/bin/login - 9600 ldterm,ttcompat ttya login:  - tvi925 y  #
zsmon          ttymon         ttyb           u    root     /dev/term/b I -
/usr/bin/login - 9600 ldterm,ttcompat ttyb login:  - tvi925 y  #
2) Truss of init -process will show trace similar to the one below.
# /usr/bin/truss -eafl -p 1
...
1/1:                Incurred fault #6, FLTBOUNDS  %pc = 0xFF3B76B8
1/1:                  siginfo: SIGSEGV SEGV_MAPERR addr=0x0000002C
1/1:                Received signal #11, SIGSEGV [caught]
1/1:                  siginfo: SIGSEGV SEGV_MAPERR addr=0x0000002C
1/1:            setcontext(0xFFBEF088)

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms