KMS/OKM - How to Upgrade the SCA6000 Firmware (Doc ID 1291307.1)

Last updated on OCTOBER 28, 2015

Applies to:

Oracle Key Manager - Version 2.0.0 to 2.5.2 [Release 2.0]
Sun StorageTek Crypto Key Management System - Version Not Applicable and later
Information in this document applies to any platform.
Checked for relevance on 2-Nov-2011.
Checked for relevance on 24-Apr-2013.

Goal

Some SCA6000 FRU's are running firmware 1.0.x which is not compatible with KMS (OKM) 2.x.x
If you try and install a card with this firmware, it will not boot up and initialize.  It will give this warning message:

warning: mca0 Driver and firmware is incompatible.

The SCA6000 board can be upgraded outside of the KMS process .  Please find below the procedure on how to upgrade the SCA6000 firmware in a regular SPARC or X86 Solaris 10 server.

Solution

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms