During an upgrade, "vda-install" stops due to demanding that former secondaries are still part of Oracle Virtual Desktop Infrastucture cluster

(Doc ID 1363742.1)

Last updated on JANUARY 06, 2015

Applies to:

Oracle Virtual Desktop Infrastructure - Version 3.1 and later
Information in this document applies to any platform.


When upgrading a Oracle Virtual Desktop Infrastucture installation, the install script "vda-install" will fail during upgrade when it compares preserved-hosts vs configured.  Error messages will be

Error: cannot preserve existing configuration



All Oracle VDI Hosts should be preserved.


Some secondaries were removed with vda-install -u before the upgrade was attempted.


Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms