fcinfo Reports "No Adapters Found" and cfgadm Does Not Show FC Adapters (HBAs) (Doc ID 1426095.1)

Last updated on AUGUST 18, 2016

Applies to:

Qlogic FC HBA - Version Not Applicable to Not Applicable [Release N/A]
Emulex FC HBA - Version Not Applicable to Not Applicable [Release N/A]
Information in this document applies to any platform.

Symptoms

  

If Solaris OS was newly installed the issue maybe OS is missing some packages/patches. Boot server from a Oracle source media, such as, CDROM/DVD then check if still have issue or not.

  

A Solaris host with seemingly functional FC HBA ports is unable to display those ports with the 'cfgadm' or 'fcinfo' commands.

 

# cfgadm -al          (NOTE: No FC HBA ports listed below)
Ap_Id           Type      Receptacle  Occupant     Condition
c0              scsi-bus  connected   configured   unknown
c0::dsk/c0t0d0  CD-ROM    connected   configured   unknown
usb0/1          unknown   empty       unconfigured ok
usb0/2          unknown   empty       unconfigured ok
usb0/3          unknown   empty       unconfigured ok
usb0/4          unknown   empty       unconfigured ok
 
# cfgadm -al -o show_FCP_dev
cfgadm: Configuration administration not supported
 
 
# fcinfo hba-port (Solaris 10 and above only)
No Adapters Found.

Despite the output above, the FC HBA ports are visible with 'luxadm -e port' and target devices (disk/tape) are functional for regular I/O.

 
NOTE: The above is true for SPARC. On x64/x86 systems, even the 'luxadm' output will not report any FC HBA ports.

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms