Luupgrade Fails with "Installation Of <Sunwxorg-Compatlinks> Partially Failed" (Doc ID 1437467.1)

Last updated on SEPTEMBER 22, 2014

Applies to:

Solaris SPARC Operating System - Version 10 3/05 and later
Information in this document applies to any platform.

Symptoms

An luupgrade fails with following messages:

luupgrade: WARNING: <1> packages failed to install properly on boot environment <SOL10>.
luupgrade: INFORMATION: The file
</var/sadm/system/data/upgrade_failed_pkgadds> on boot environment <SOL10>
contains a list of packages that failed to upgrade or install properly.
luupgrade: INFORMATION: Review the files listed above. Remember that all
of the files are located on boot environment <SOL10>. Before you activate
boot environment <SOL10>, determine if any additional system maintenance
is required or if additional media of the software distribution must be
installed.
luupgrade: DEBUG(*): Unmounting ABE mount point </a> from ICF file </tmp/.liveupgrade.9070.5409/.luupgrade.beicf>.
luupgrade: The Solaris upgrade of the boot environment <SOL10> is partially complete.



The upgrade_log contains the following messages:

Doing pkgadd of SUNWxorg-compatlinks to /
pkgadd: ERROR: unable to create package object </a/usr/lib/X11>.
file type <s> expected <d> actual
unable to remove existing directory at </a/usr/lib/X11>

Installation of <SUNWxorg-compatlinks> partially failed.
pkgadd return code = 2

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms