pkg install gives error: no solution was found to satisfy constraints

(Doc ID 1488993.1)

Last updated on FEBRUARY 18, 2016

Applies to:

Solaris SPARC Operating System - Version 11 11/11 and later
Information in this document applies to any platform.

Symptoms

Package fails to install with error:  No solution was found to satisfy constraints.

Following is an example of this failure:

 

#  pkg install --accept pkg://solaris/developer/java/jdk-7@1.7.0.5,5.11-0.175.0.10.0.2.0:20120716T225029Z
Creating Plan -
pkg install: No solution was found to satisfy constraints

maintained incorporations:

  pkg://solaris/consolidation/ldoms/ldoms-incorporation@0.5.11,5.11-0.175.0.8.0.3.0:20120525T222045Z
  pkg://solaris/consolidation/gfx/gfx-incorporation@0.5.11,5.11-0.175.0.0.0.2.0:20111019T144752Z
  pkg://solaris/consolidation/vpanels/vpanels-incorporation@0.5.11,5.11-0.175.0.0.0.1.778:20111012T230640Z
  pkg://solaris/consolidation/admin/admin-incorporation@0.5.11,5.11-0.175.0.0.0.2.0:20111019T144751Z
  pkg://solaris/consolidation/SunVTS/SunVTS-incorporation@0.5.11,5.11-0.175.0.7.0.3.0:20120421T004225Z
  pkg://solaris/consolidation/solaris_re/solaris_re-incorporation@0.5.11,5.11-0.175.0.0.0.2.0:20111019T122734Z
  pkg://solaris/consolidation/cacao/cacao-incorporation@0.5.11,5.11-0.175.0.6.0.1.0:20120323T204721Z
  pkg://solaris/consolidation/jdmk/jdmk-incorporation@0.5.11,5.11-0.173.0.0.0.0.0:20110828T210111Z
  pkg://solaris/consolidation/nvidia/nvidia-incorporation@0.5.11,5.11-0.175.0.0.0.0.0:20110927T192422Z
  pkg://solaris/consolidation/dbtg/dbtg-incorporation@0.5.11,5.11-0.175.0.0.0.2.0:20111019T144751Z
  pkg://solaris/consolidation/ips/ips-incorporation@0.5.11,5.11-0.175.0.7.0.4.0:20120430T200820Z
  pkg://solaris/consolidation/cde/cde-incorporation@0.5.11,5.11-0.175.0.0.0.0.0:20110927T191905Z
  pkg://solaris/consolidation/smcc/smcc-incorporation@0.5.11,5.11-0.175.0.0.0.2.0:20111019T144755Z
  pkg://solaris/consolidation/osnet/osnet-incorporation@0.5.11,5.11-0.175.0.8.0.5.1:20120618T173352Z
  pkg://solaris/consolidation/man/man-incorporation@0.5.11,5.11-0.175.0.0.0.0.0:20110927T192523Z
  pkg://solaris/consolidation/desktop/desktop-incorporation@0.5.11,5.11-0.175.0.8.0.3.0:20120524T231907Z
  pkg://solaris/consolidation/l10n/l10n-incorporation@0.5.11,5.11-0.175.0.0.0.1.765:20111012T043917Z
  pkg://solaris/consolidation/nspg/nspg-incorporation@0.5.11,5.11-0.175.0.0.0.2.0:20111019T144753Z
  pkg://solaris/consolidation/sic_team/sic_team-incorporation@0.5.11,5.11-0.172.0.0.0.0.0:20110816T070737Z
  pkg://solaris/consolidation/sunpro/sunpro-incorporation@0.5.11,5.11-0.174.0.0.0.0.0:20110921T184135Z
  pkg://solaris/entire@0.5.11,5.11-0.175.0.8.0.5.0:20120618T173955Z
  pkg://solaris/consolidation/cns/cns-incorporation@0.5.11,5.11-0.175.0.0.0.1.0:20111012T230319Z
  pkg://solaris/consolidation/X/X-incorporation@0.5.11,5.11-0.175.0.8.0.2.1226:20120519T002403Z
  pkg://solaris/consolidation/install/install-incorporation@0.5.11,5.11-0.175.0.7.0.2.0:20120416T210633Z
  pkg://solaris/consolidation/userland/userland-incorporation@0.5.11,5.11-0.175.0.8.0.4.0:20120601T170434Z
  pkg://solaris/consolidation/desktop/gnome-incorporation@0.5.11,5.11-0.175.0.8.0.3.0:20120524T231910Z
  pkg://solaris/consolidation/sfw/sfw-incorporation@0.5.11,5.11-0.175.0.0.0.2.0:20111019T144754Z

Plan Creation: dependency error(s) in proposed packages:
  No suitable version of required package pkg://solaris/consolidation/java/java-incorporation@0.5.11,5.11-0.175.0.8.0.1.0:20120515T151724Z found:
    Reject:  pkg://solaris/consolidation/java/java-incorporation@0.5.11,5.11-0.175.0.8.0.1.0:20120515T151724Z
    Reason:  All versions matching 'incorporate' dependency pkg:/developer/java/jdk-7@1.7.0.3,5.11-0.175.0.8.0.1.0 are rejected
      Reject:  pkg://solaris/developer/java/jdk-7@1.7.0.3,5.11-0.175.0.8.0.1.0:20120515T151727Z
      Reason:  This version excluded by specified installation version
  No suitable version of required package pkg://solaris/runtime/java/jre-7@1.7.0.5,5.11-0.175.0.10.0.2.0:20120716T225057Z found:
    Reject:  pkg://solaris/runtime/java/jre-7@1.7.0.5,5.11-0.175.0.10.0.2.0:20120716T225057Z
    Reason:  All versions matching 'require' dependency pkg:/consolidation/java/java-incorporation are rejected
      Reject:  pkg://solaris/consolidation/java/java-incorporation@0.5.11,5.11-0.173.0.0.0.0.0:20110828T210417Z
      Reason:  Newer version pkg://solaris/consolidation/java/java-incorporation@0.5.11,5.11-0.175.0.8.0.1.0:20120515T151724Z is already installed
               This version is excluded by installed incorporation pkg://solaris/entire@0.5.11,5.11-0.175.0.8.0.5.0:20120618T173955Z
      Reject:  pkg://solaris/consolidation/java/java-incorporation@0.5.11,5.11-0.175.0.8.0.1.0:20120515T151724Z
      Reason:  All versions matching 'incorporate' dependency pkg:/developer/java/jdk-7@1.7.0.3,5.11-0.175.0.8.0.1.0 are rejected
        Reject:  pkg://solaris/developer/java/jdk-7@1.7.0.3,5.11-0.175.0.8.0.1.0:20120515T151727Z
        Reason:  This version excluded by specified installation version
      Reject:  pkg://solaris/consolidation/java/java-incorporation@0.5.11,5.11-0.175.0.9.0.2.0:20120618T204453Z
               pkg://solaris/consolidation/java/java-incorporation@0.5.11,5.11-0.175.0.10.0.2.0:20120716T225028Z
      Reason:  This version is excluded by installed incorporation pkg://solaris/entire@0.5.11,5.11-0.175.0.8.0.5.0:20120618T173955Z
  No suitable version of required package pkg://solaris/developer/build/onbld@0.5.11,5.11-0.151.0.1.3:20110121T162616Z found:
    Reject:  pkg://solaris/developer/build/onbld@0.5.11,5.11-0.151.0.1.3:20110121T162616Z
    Reason:  All acceptable versions of 'require' dependency on pkg:/runtime/python-24 are obsolete
  No suitable version of required package pkg://solaris/developer/build/onbld@0.5.11,5.11-0.151.0.1:20101104T230755Z found:
    Reject:  pkg://solaris/developer/build/onbld@0.5.11,5.11-0.151.0.1:20101104T230755Z
    Reason:  All acceptable versions of 'require' dependency on pkg:/runtime/python-24 are obsolete
  No suitable version of required package pkg://solaris/developer/java/jdk@1.7.0.5,5.11-0.175.0.10.0.2.0:20120716T225047Z found:
    Reject:  pkg://solaris/developer/java/jdk@1.7.0.5,5.11-0.175.0.10.0.2.0:20120716T225047Z
    Reason:  All versions matching 'require' dependency pkg:/consolidation/java/java-incorporation are rejected
      Reject:  pkg://solaris/consolidation/java/java-incorporation@0.5.11,5.11-0.173.0.0.0.0.0:20110828T210417Z
      Reason:  Newer version pkg://solaris/consolidation/java/java-incorporation@0.5.11,5.11-0.175.0.8.0.1.0:20120515T151724Z is already installed
               This version is excluded by installed incorporation pkg://solaris/entire@0.5.11,5.11-0.175.0.8.0.5.0:20120618T173955Z
      Reject:  pkg://solaris/consolidation/java/java-incorporation@0.5.11,5.11-0.175.0.8.0.1.0:20120515T151724Z
      Reason:  All versions matching 'incorporate' dependency pkg:/developer/java/jdk-7@1.7.0.3,5.11-0.175.0.8.0.1.0 are rejected
        Reject:  pkg://solaris/developer/java/jdk-7@1.7.0.3,5.11-0.175.0.8.0.1.0:20120515T151727Z
        Reason:  This version excluded by specified installation version
      Reject:  pkg://solaris/consolidation/java/java-incorporation@0.5.11,5.11-0.175.0.9.0.2.0:20120618T204453Z
               pkg://solaris/consolidation/java/java-incorporation@0.5.11,5.11-0.175.0.10.0.2.0:20120716T225028Z
      Reason:  This version is excluded by installed incorporation pkg://solaris/entire@0.5.11,5.11-0.175.0.8.0.5.0:20120618T173955Z
  No suitable version of required package pkg://solaris/developer/java/jdk@1.7.0.5,5.11-0.175.0.9.0.2.0:20120618T204525Z found:
    Reject:  pkg://solaris/developer/java/jdk@1.7.0.5,5.11-0.175.0.9.0.2.0:20120618T204525Z
    Reason:  All versions matching 'require' dependency pkg:/consolidation/java/java-incorporation are rejected
      Reject:  pkg://solaris/consolidation/java/java-incorporation@0.5.11,5.11-0.173.0.0.0.0.0:20110828T210417Z
      Reason:  Newer version pkg://solaris/consolidation/java/java-incorporation@0.5.11,5.11-0.175.0.8.0.1.0:20120515T151724Z is already installed
               This version is excluded by installed incorporation pkg://solaris/entire@0.5.11,5.11-0.175.0.8.0.5.0:20120618T173955Z
      Reject:  pkg://solaris/consolidation/java/java-incorporation@0.5.11,5.11-0.175.0.8.0.1.0:20120515T151724Z
      Reason:  All versions matching 'incorporate' dependency pkg:/developer/java/jdk-7@1.7.0.3,5.11-0.175.0.8.0.1.0 are rejected
        Reject:  pkg://solaris/developer/java/jdk-7@1.7.0.3,5.11-0.175.0.8.0.1.0:20120515T151727Z
        Reason:  This version excluded by specified installation version
      Reject:  pkg://solaris/consolidation/java/java-incorporation@0.5.11,5.11-0.175.0.9.0.2.0:20120618T204453Z
               pkg://solaris/consolidation/java/java-incorporation@0.5.11,5.11-0.175.0.10.0.2.0:20120716T225028Z
      Reason:  This version is excluded by installed incorporation pkg://solaris/entire@0.5.11,5.11-0.175.0.8.0.5.0:20120618T173955Z
  No suitable version of required package pkg://solaris/developer/java/jdk@1.7.0.3,5.11-0.175.0.8.0.1.0:20120515T151744Z found:
    Reject:  pkg://solaris/developer/java/jdk@1.7.0.3,5.11-0.175.0.8.0.1.0:20120515T151744Z
    Reason:  All versions matching 'require' dependency pkg:/consolidation/java/java-incorporation are rejected
      Reject:  pkg://solaris/consolidation/java/java-incorporation@0.5.11,5.11-0.173.0.0.0.0.0:20110828T210417Z
      Reason:  Newer version pkg://solaris/consolidation/java/java-incorporation@0.5.11,5.11-0.175.0.8.0.1.0:20120515T151724Z is already installed
               This version is excluded by installed incorporation pkg://solaris/entire@0.5.11,5.11-0.175.0.8.0.5.0:20120618T173955Z
      Reject:  pkg://solaris/consolidation/java/java-incorporation@0.5.11,5.11-0.175.0.8.0.1.0:20120515T151724Z
      Reason:  All versions matching 'incorporate' dependency pkg:/developer/java/jdk-7@1.7.0.3,5.11-0.175.0.8.0.1.0 are rejected
        Reject:  pkg://solaris/developer/java/jdk-7@1.7.0.3,5.11-0.175.0.8.0.1.0:20120515T151727Z
        Reason:  This version excluded by specified installation version
      Reject:  pkg://solaris/consolidation/java/java-incorporation@0.5.11,5.11-0.175.0.9.0.2.0:20120618T204453Z
               pkg://solaris/consolidation/java/java-incorporation@0.5.11,5.11-0.175.0.10.0.2.0:20120716T225028Z
      Reason:  This version is excluded by installed incorporation pkg://solaris/entire@0.5.11,5.11-0.175.0.8.0.5.0:20120618T173955Z
  No suitable version of required package pkg://solaris/developer/build/onbld@0.5.11,5.11-0.151.0.1.8:20110620T221620Z found:
    Reject:  pkg://solaris/developer/build/onbld@0.5.11,5.11-0.151.0.1.8:20110620T221620Z
    Reason:  All acceptable versions of 'require' dependency on pkg:/runtime/python-24 are obsolete

Plan Creation: Errors in installed packages due to proposed changes:

  No suitable version of installed package pkg://solaris/consolidation/java/java-incorporation@0.5.11,5.11-0.175.0.8.0.1.0:20120515T151724Z found
    Reject:  pkg://solaris/consolidation/java/java-incorporation@0.5.11,5.11-0.175.0.8.0.1.0:20120515T151724Z
    Reason:  All versions matching 'incorporate' dependency pkg:/developer/java/jdk-7@1.7.0.3,5.11-0.175.0.8.0.1.0 are rejected
      Reject:  pkg://solaris/developer/java/jdk-7@1.7.0.3,5.11-0.175.0.8.0.1.0:20120515T151727Z
      Reason:  This version excluded by specified installation version
    Reject:  pkg://solaris/consolidation/java/java-incorporation@0.5.11,5.11-0.175.0.9.0.2.0:20120618T204453Z
             pkg://solaris/consolidation/java/java-incorporation@0.5.11,5.11-0.175.0.10.0.2.0:20120716T225028Z
    Reason:  This version is excluded by installed incorporation pkg://solaris/entire@0.5.11,5.11-0.175.0.8.0.5.0:20120618T173955Z

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms