Installing ASR in Mammoth 2.3.1 Step 15 Fails or Using 'mammoth-reconfig add asr' Fails with "Asr::Setupasr/Package [sun-servicetag]/ensure) change from absent to latest failed" (Doc ID 1601635.1)

Last updated on MAY 06, 2014

Applies to:

Big Data Appliance Integrated Software - Version 2.3.1 and later
Big Data Appliance X3-2 Full Rack - Version All Versions and later
Big Data Appliance X3-2 Starter Rack - Version All Versions and later
Big Data Appliance X4-2 Full Rack - Version All Versions and later
Big Data Appliance X4-2 Starter Rack - Version All Versions and later
Linux x86-64

Symptoms

Installing Mammoth V2.3.1 step 15 or running 'mammoth-reconfig add asr' fails with errors like the following:

Error [7327]: (//<server 1>//Stage[main]/Asr::Setupasr/Package
[sun-servicetag]/ensure) change from absent to latest failed: Could not update:
Execution of '/bin/rpm -i --oldpackage /root/Extras/ASR/sun-servicetag-1.1.5-
1.i386.rpm' returned 1: error: Failed
dependencies:#012#011/usr/lib/libxml2.so.2 is needed by sun-servicetag-1.1.5-
1.i386#012#011libuuid.so.1 is needed by sun-servicetag-1.1.5-
1.i386#012#011libxml2.so.2 is needed by sun-servicetag-1.1.5-
1.i386#012#011libz.so.1 is needed by sun-servicetag-1.1.5-1.i386#012 at
/opt/oracle/BDAMammoth/puppet/modules/asr/manifests/setupasr.pp:9

 

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms