Exadata: Downgrading IB switches fail with Error messages: [FAIL ] controlled_handover must be TRUE, value in /etc/opensm/opensm.conf is FALSE . ACTION: Correct or add controlled_handover in /etc/opensm/opensm.conf (Doc ID 1633947.1)

Last updated on MARCH 17, 2014

Applies to:

Exadata Database Machine V2 - Version All Versions and later
Oracle Exadata Hardware - Version 11.2.0.1 and later
Exadata Database Machine X2-2 Hardware - Version All Versions and later
Exadata Database Machine X2-8 - Version All Versions and later
Exadata X3-2 Hardware - Version All Versions and later
Information in this document applies to any platform.

Symptoms

 In case of unsuccessful upgrade of complete exadata stack you may need to downgrade the ibswitch version also back to previous version, in that case, you may receive the below error.
 here during downgrade of IB switches from version : 2.1.3-4  to 1.3.3-2 , the below error is faced
 
 [root@xxxxdb01 patch_11.2.3.3.0.131014.1]# ./patchmgr -ibswitches -downgrade -ibswitch_precheck

 [INFO     ] Starting post-update validation on xxxx-ib
[SUCCESS  ] Inifiniband switch xxxx-ib is at target patching level
[SUCCESS  ] Verifying host details in /etc/hosts and /etc/sysconfig/network-scripts/ifcfg-eth0 /etc/sysconfig/network-scripts/ifcfg-eth1 for xxxx-ib
[SUCCESS  ] Verifying that xxxx-ib has at least 1 NTP Server, found 1
[FAIL     ] controlled_handover must be TRUE, value in /etc/opensm/opensm.conf is FALSE . ACTION: Correct or add controlled_handover in /etc/opensm/opensm.conf in xxxx-ib
[INFO     ] Manually validate the following entries Date:(YYYY-MM-DD) 2014-03-09 Time:(HH:MM:SS) 18:33:20
[FAIL     ] Post-update validation on xxxx-ib
[INFO     ] Post-check validation on IBSwitch xxxx-ib
[FAIL     ] Update switch xxxx-ib to 1.3.3_2
[INFO     ] Aborting the process. Not going to try anymore switches. Retry after resolving the problems.
[FAIL     ] Overall status

FAILED: Details in files /var/log/cellos/upgradeIBSwitch.log /u01/patches/CELL/patch_11.2.3.3.0.131014.1/patchmgr.stdout, /u01/patches/CELL/patch_11.2.3.3.0.131014.1/patchmgr.stderr
FAILED: DONE: Downgrade InfiniBand switch(es) to 1.3.3-2.

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms