ACSLS - Drives Are Offline with "No drive installed at address" and "STATUS_CONFIGURATION_ERROR" Errors (Doc ID 1674695.1)

Last updated on MARCH 21, 2017

Applies to:

Sun StorageTek Auto Cartridge Sys Lib SW (ACSLS) - Version 7.0 to 8.3 [Release 7.0 to 8.0]
Sun StorageTek SL8500 Modular Library System - Version All Versions and later
Sun StorageTek SL3000 Modular Library System - Version All Versions and later
Information in this document applies to any platform.

Symptoms

Drives are switched to offline and unable to come online. Getting hardware errors:

ACSSA> vary drive 0,0,1,4 online
2014-05-15 10:56:22 0 drive 0, 0, 1, 4 reported a hardware error.
Vary: Vary failed, Library configuration error.
ACSSA> 2014-05-15 10:56:22 30753 Library configuration error.
2014-05-15 10:56:24 0 drive 0, 0, 1, 4 reported a hardware error.
2014-05-15 10:56:24 0 Library configuration error.


The acsss_event.log shows "No drive intalled at address" errors:
---
 
2014-05-15 10:56:22 ACSSA[0]:
2469 E sa_demux.c 1 296
drive 0, 0, 1, 4 reported a hardware error.

2014-05-15 10:56:22 ACSSA[30753]:
1422 N sa_demux.c 1 296
Library configuration error.

2014-05-15 10:56:23 ACSLM[0]:
41 N lm_wait_proc.c 1 460
lm_wait_proc: Unexpected exit status STATUS_CONFIGURATION_ERROR from command
VARY detected

2014-05-15 10:56:24 ACSLH[0]:
2377 N Co_ProcessResponses.C 1 589
ACS: 0; LMU error: Co_4400:st_parse_error:
Request: Transport Serial Number
Error: 0971 - LSM logical error: No drive installed at address


The drives below are in offline mode :
0, 0, 1, 3 offline available T9940B
0, 0, 1, 4 offline available T9940B
0, 0, 1, 7 offline available T9940B
0, 0, 1, 8 offline available T9940B
0, 0, 1,11 offline available T9940B
0, 0, 1,12 offline available T9940B
0, 1, 1, 4 offline available T9940B
0, 1, 1, 6 offline available T9940B
0, 1, 1, 7 offline available T9940B
0, 1, 1, 8 offline available T9940B
0, 1, 1,11 offline available T9940B
0, 1, 1,12 offline available T9940B
0, 7, 1, 8 offline available T9940B
0, 4, 1,11 offline available T9940B
0, 3, 1, 5 offline in use T9940B


During ACSLS start up, the drives listed above were showing "Configuration failed to verify" errors:

---
2014-04-12 12:10:30 RECOVERY[0]:
83 N re_verf_drv.c 1 413
re_verf_drv: Drive 0, 0, 1, 3: Configuration failed to verify

2014-04-12 12:10:30 RECOVERY[0]:
83 N re_verf_drv.c 1 413
re_verf_drv: Drive 0, 0, 1, 4: Configuration failed to verify

2014-04-12 12:10:30 RECOVERY[0]:
83 N re_verf_drv.c 1 413
re_verf_drv: Drive 0, 0, 1, 7: Configuration failed to verify

2014-04-12 12:10:30 RECOVERY[0]:
83 N re_verf_drv.c 1 413
re_verf_drv: Drive 0, 0, 1, 8: Configuration failed to verify

2014-04-12 12:10:30 RECOVERY[0]:
83 N re_verf_drv.c 1 413
re_verf_drv: Drive 0, 0, 1,11: Configuration failed to verify

2014-04-12 12:10:30 RECOVERY[0]:
83 N re_verf_drv.c 1 413
re_verf_drv: Drive 0, 0, 1,12: Configuration failed to verify

2014-04-12 12:10:30 RECOVERY[0]:
83 N re_verf_drv.c 1 413
re_verf_drv: Drive 0, 1, 1, 4: Configuration failed to verify

2014-04-12 12:10:30 RECOVERY[0]:
83 N re_verf_drv.c 1 413
re_verf_drv: Drive 0, 1, 1, 6: Configuration failed to verify

2014-04-12 12:10:32 RECOVERY[0]:
83 N re_verf_drv.c 1 413
re_verf_drv: Drive 0, 1, 1, 7: Configuration failed to verify

2014-04-12 12:10:32 RECOVERY[0]:
83 N re_verf_drv.c 1 413
re_verf_drv: Drive 0, 1, 1, 8: Configuration failed to verify

2014-04-12 12:10:32 RECOVERY[0]:
83 N re_verf_drv.c 1 413
re_verf_drv: Drive 0, 1, 1,11: Configuration failed to verify

2014-04-12 12:10:32 RECOVERY[0]:
83 N re_verf_drv.c 1 413
re_verf_drv: Drive 0, 1, 1,12: Configuration failed to verify

2014-04-12 12:10:32 RECOVERY[0]:
83 N re_verf_drv.c 1 413
re_verf_drv: Drive 0, 3, 1, 5: Configuration failed to verify

2014-04-12 12:10:32 RECOVERY[0]:
83 N re_verf_drv.c 1 413
re_verf_drv: Drive 0, 4, 1,11: Configuration failed to verify


The library Error Warn Info Event log shows "Drive not found" errors.
---
  Time : 2014-05-15T11:28:36.915
  Device Address : 1.0.0.0.0
  User : root
  Requester : hli0
  Activity : queryDrive
  Request Id : 13913110
  Level : error
  Result Code : 1216
  Text : "Drive not found - getDrive drive null"
  Parameters : drive=0,1,3,-1
  
  
  Time : 2014-05-15T11:28:39.515
  Device Address : 1.0.0.0.0
  User : root
  Requester : hli0
  Activity : queryDrive
  Request Id : 13913130
  Level : error
  Result Code : 1216
  Text : "Drive not found - getDrive drive null"
  Parameters : drive=0,1,3,-1
  
  
  Time : 2014-05-15T11:29:31.585
  Device Address : 1.0.0.0.0
  User : root
  Requester : hli0
  Activity : queryDrive
  Request Id : 13913150
  Level : error
  Result Code : 1216
  Text : "Drive not found - getDrive drive null"
  Parameters : drive=0,1,4,-1
  
...

Changes

Drives were removed from the library about a month ago.

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms