Firefox Users Report Error, "...SSL received a weak ephemeral Diffie-Hellman key" when Connecting to Secure Global Desktop After Upgrading to Firefox 39 (Doc ID 2029008.1)

Last updated on DECEMBER 26, 2016

Applies to:

Oracle Secure Global Desktop - Version 4.63 to 5.1 [Release 4.0 to 5.0]
Information in this document applies to any platform.

Symptoms

Firefox users may report the following error message when connecting to Secure Global Desktop (SGD) or SGD Gateway servers:

This behavior is only seen on Secure Global Desktop, version 5.1 and earlier. 

Changes

Mozilla Firefox users have either installed, or upgraded their local browser to Firefox version 39 or later. 

Support Status

Please note that Mozilla Firefox version 39 is not a formally tested and certified browser combination for Oracle Secure Global Desktop 5.1 and earlier.  For late-breaking information regarding the latest formally supported browser combinations to use with Oracle's SGD and SGD Gateway products, please see:

Addendum: Tested Client Browser Combinations for Secure Global Desktop (Doc ID 1950093.1)

Users who restore their upgraded browser to Firefox version 38 or earlier have reported successful reconnection to their SGD servers.

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms