How to Restore Corrupted Patch Commands in Secure Global Desktop

(Doc ID 2075413.1)

Last updated on NOVEMBER 11, 2015

Applies to:

Oracle Secure Global Desktop - Version 5.2 to 5.2 [Release 5.0]
Information in this document applies to any platform.

Symptoms

The Secure Global Desktop (SGD) Administrator reports that patch installation fails on a Secure Global Desktop 5.2 system, with an error like the following:

# ./tarantella patch add --file /tmp/Bundle_Patch_52p2_i3li.tar.gz
Unpacking the patch file: /tmp/Bundle_Patch_52p2_i3li.tar.gz
This patch requires version 2.0 of the patch add mechanism.
Please update your patch mechanism.

This error state may be verified by querying the version of the patch mechanism:

# ./tarantella patch list --version
Current command versions:
add: 1.4
list: 1.4
remove: 1.4
update: 1.4

Commands strings:
add: 1.4
list: 1.4
remove: 1.4

 

Changes

Secure Global Desktop 5.2 should install with version 2.0 of the SGD Patch Mechanism by default.   All patches for this platform will be built upon this baseline.  Earlier versions of the patch mechanism will not meet the prerequisite requirements for new patch installation.

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms