Dbnodeupdate Fails upgrading To 12.1.2.2.0 with dependencies related to elfutils, and ntsysv packages (Doc ID 2077349.1)

Last updated on NOVEMBER 16, 2015

Applies to:

Exadata X3-2 Hardware - Version All Versions and later
Information in this document applies to any platform.

Symptoms

dbnodeupdate fails upgrading from 12.1.2.1.2 to 12.1.2.2.0

dbnodeupdate.log shows errors related to dependencies.

--> Finished Dependency Resolution
Error: Package: glibc-devel-2.12-1.149.el6_6.7.i686 (installed)
Requires: glibc-headers = 2.12-1.149.el6_6.7
Removing: glibc-headers-2.12-1.149.el6_6.7.x86_64 (installed)
glibc-headers = 2.12-1.149.el6_6.7
Updated By: glibc-headers-2.12-1.166.el6_7.1.x86_64 (exadata_generated_101115160654)
glibc-headers = 2.12-1.166.el6_7.1
Error: Package: elfutils-libelf-devel-0.158-3.2.el6.x86_64 (installed)
Requires: elfutils-libelf(x86-64) = 0.158-3.2.el6
Removing: elfutils-libelf-0.158-3.2.el6.x86_64 (installed)
elfutils-libelf(x86-64) = 0.158-3.2.el6
Updated By: elfutils-libelf-0.161-3.el6.x86_64 (exadata_generated_101115160654)
elfutils-libelf(x86-64) = 0.161-3.el6
Error: Package: glibc-2.12-1.149.el6_6.7.i686 (installed)
Requires: glibc-common = 2.12-1.149.el6_6.7
Removing: glibc-common-2.12-1.149.el6_6.7.x86_64 (installed)
glibc-common = 2.12-1.149.el6_6.7
Updated By: glibc-common-2.12-1.166.el6_7.1.x86_64 (exadata_generated_101115160654)
glibc-common = 2.12-1.166.el6_7.1
Error: Package: elfutils-0.158-3.2.el6.x86_64 (installed)
Requires: elfutils-libs(x86-64) = 0.158-3.2.el6
Removing: elfutils-libs-0.158-3.2.el6.x86_64 (installed)
elfutils-libs(x86-64) = 0.158-3.2.el6
Updated By: elfutils-libs-0.161-3.el6.x86_64 (exadata_generated_101115160654)
elfutils-libs(x86-64) = 0.161-3.el6
Error: Package: elfutils-0.158-3.2.el6.x86_64 (installed)
Requires: elfutils-libelf(x86-64) = 0.158-3.2.el6
Removing: elfutils-libelf-0.158-3.2.el6.x86_64 (installed)
elfutils-libelf(x86-64) = 0.158-3.2.el6
Updated By: elfutils-libelf-0.161-3.el6.x86_64 (exadata_generated_101115160654)
elfutils-libelf(x86-64) = 0.161-3.el6
Error: Package: ntsysv-1.3.49.3-2.el6_4.1.x86_64 (installed)
Requires: chkconfig = 1.3.49.3-2.el6_4.1
Removing: chkconfig-1.3.49.3-2.el6_4.1.x86_64 (installed)
chkconfig = 1.3.49.3-2.el6_4.1
Updated By: chkconfig-1.3.49.3-5.el6.x86_64 (exadata_generated_101115160654)
chkconfig = 1.3.49.3-5.el6
You could try using --skip-broken to work around the problem
** Found 3 pre-existing rpmdb problem(s), 'yum check' output follows:
exadata-sun-computenode-exact-12.1.2.1.2.150617.1-1.x86_64 has missing requires of config(irqbalance) = ('2', '1.0.4', '10.0.3.el6')
exadata-sun-computenode-exact-12.1.2.1.2.150617.1-1.x86_64 has missing requires of irqbalance = ('2', '1.0.4', '10.0.3.el6')
exadata-sun-computenode-exact-12.1.2.1.2.150617.1-1.x86_64 has missing requires of irqbalance(x86-64) = ('2', '1.0.4', '10.0.3.el6')

 

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms