My Oracle Support Banner

The Performance of ZFS I/O Requests Is Poor with Emulex 8Gbps FC (Doc ID 2100829.1)

Last updated on FEBRUARY 04, 2019

Applies to:

Solaris Operating System - Version 11.1 to 11.3 [Release 11.0]
Solaris Operating System - Version 10 6/06 U2 to 10 1/13 U11 [Release 10.0]
Information in this document applies to any platform.

Symptoms

Problem specification and summary:
The performance of ZFS I/O requests is poor when using Emulex 8Gbps FC


Detailed description:
In SAN boot environment of emulex 8G FC card on Solaris 11.1, it takes a long time to make a backup of zfs rpool.

As a result of iostat, the status continues with the value of %w high as follows:




Background information:

1. What is the frequency of problem occurrence (always/random/periodically..etc) since then?
    What is the trend of problem occurrence (increasing/decreasing..etc) since then?


   This issue always occurs when executing "zfs send" to rpool.


2.  This issue does not occur in the same  environment with QLogic 8Gbps  FC card.

3.  Describe any workaround you are using to avoid this problem.

    Set "zfs_vdev_enable_mvector=0" in /etc/system.




Changes

 

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Changes
Cause
Solution
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.