Install Of Exalytics R2.1 (2.0.0.1.0) Errors With Failed Dependencies on policycoreutils-python On X-5-4 (Doc ID 2193410.1)

Last updated on DECEMBER 01, 2016

Applies to:

Oracle Exalytics Software - Version 2.0.0.1.0 and later
Information in this document applies to any platform.

Symptoms

When installing Exalytics 2.0.0.1.0 on an Exalytics X5-4 server, following the instructions in the
  Fusion Middleware Oracle Exalytics In-Memory Machine Installation and Administration Guide for Linux

the update.sh script, from patch p20431965_20001_Linux-x86-64, returned the following errors, regarding failed dependencies:

# ./update.sh
current_kernel_version=3.8.13-68.3.3.el6uek.x86_64
minimum_kernel_version=2.6.39-400.215.9.el5uek
OS Version check passed..
Update to 2.2.0.1.0.ovs-3.3.3 starting at Wed Oct 5 09:23:02 PDT 2016
Removing unnecessary packages...
Skipping removing rpm kernel-ib-devel as it doesn't exist...
Skipping removing rpm kernel-ib as it doesn't exist...
Skipping removing rpm ibvf-config as it doesn't exist...
Skipping removing rpm OpenIPMI-tools as it doesn't exist...
Done
Running new install steps...
Preparing...
...
Successfully installed exalogic.tools
.....[exalogic.tools] := Post Transaction called...............
Running update...
...
postInstall (exalytics-flash) 1 ...
[EXALYTICS_INFO:GENERAL] Updating exalytics-flash-config file to set
FLASH_INSTALL_TYPE=OVS ...
postInstall (exalytics-flash) 1; done
Preparing...
...
Starting snmpd
Starting snmpd: [ OK ]
Registering Service lsi_mrdsnmpd
Starting LSI SNMP Agent
Starting LSI SNMP Agent:LSI MegaRAID SNMP Agent Ver 3.18.0.2 (Oct 30th, 2012)
Started
[ OK ]
Preparing...
...
error: Failed dependencies:
libclntsh.so.11.1()(64bit) is needed by
oracle-hmp-hwmgmt-2.3.1.1-1.el6.x86_64
libfishwrap.so.4()(64bit) is needed by
oracle-hmp-hwmgmt-2.3.1.1-1.el6.x86_64
libhwmgmtcommon.so.2()(64bit) is needed by
oracle-hmp-hwmgmt-2.3.1.1-1.el6.x86_64
libnnz11.so()(64bit) is needed by
oracle-hmp-hwmgmt-2.3.1.1-1.el6.x86_64
oracle-hmp-libs is needed by oracle-hmp-hwmgmt-2.3.1.1-1.el6.x86_64
policycoreutils-python is needed by
oracle-hmp-hwmgmt-2.3.1.1-1.el6.x86_64
Preparing...
...
error: Failed dependencies:
oracle-hmp-hwmgmt is needed by oracle-hmp-snmp-2.3.1.1-1.el6.x86_64
Preparing...
...
Removing bm flash scripts...
Running post install script...
Running post patch script
file /etc/ofed/openib.conf not found
file /etc/sysconfig/network-scripts/ifcfg-bondib0 not found
file /etc/init.d/openibd not found
/usr/lib/init-exalogic-node/init-ipoib.sh not exist in /etc/rc.local ,
nothing to delete
Completed post patch script
Enabling services...
Updating dom0 memory to 16G...
Copying Exa* files...
Updating imageinfo...
Image name in imageinfo is already uptodate
finished; Wed Oct 5 09:23:31 PDT 2016
finished; Wed Oct 5 09:23:31 PDT 2016
[root@arb10 exalytics_ovs_server_base_image_2.2.0.1.0.ovs-3.3.3]# imageinfo
Exalytics 2.2.0.1.0.ovs-3.3.3 (build:r20151215.1)
.
Image version : 2.2.0.1.0.ovs-3.3.3
Image build version : 20151215.1
Creation timestamp : 2016-10-05_09-23-31
Kernel version : 3.8.13-68.3.3.el6uek.x86_64
Image activated : 2016-10-05_09-23-31
Image status : SUCCESS
.
[exalytics_ovs_server_base_image_2.2.0.1.0.ovs-3.3.3]#

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms