My Oracle Support Banner

Oracle ZFS Storage Appliance: Creating IPMP interface with underlying VLAN interfaces is created with only one underlying NIC attached (Doc ID 2392174.1)

Last updated on MAY 02, 2018

Applies to:

Integrated Software for ZFS ZS5-x Arrays - Version All Versions and later
Integrated Software for ZFS 7xx0 Arrays - Version All Versions and later
7000 Appliance OS (Fishworks)

Symptoms

When trying to create a probe-based IPMP interface using two VNIC interfaces created from datalinks using VLAN tags, one of the interfaces is showing a yellow icon on the BUI and the IPMP interface is refusing to assign the IP Address.

This interface is created from an IXGBE port which we can successfully use in VNIC with different VLAN id's.

We also see an alert in Maintenance > Problems :

Service svc:/appliance/kit/network/datalink:ixgbe455001 failed - a start, stop or refresh method failed.

 

When we looked at the interfaces in the BUI, we could see the faulted interface created with an incorrect IP address for probing.

 

When we destroyed the interfaces and datalinks in the BUI or CLI, then recreated them - we would see the same problem.

We were however, able to successfully create the IPMP interface with both underlying VNICs if we used a different VLAN-id.  However we can never create the IPMP device correctly with the desired VLAN-id.

 

Changes

This is an initial creation of these devices.

 

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.