My Oracle Support Banner

Upgrade To 4.1.0.2.0 Failing with Dependency for 'freetype' and 'fping' Packages (Doc ID 2514848.1)

Last updated on DECEMBER 03, 2019

Applies to:

Oracle Communications Session Monitor - Version 4.0 to 4.2 [Release 4.0]
Information in this document applies to any platform.

Symptoms

Upgrade to 4.1.0.2.0 failing. Upgrade failed with dependency errors. Examples below from upgrade log:

--> Processing Dependency: freetype = 2.8-12.el7 for package: ocsm-4.1.0.2.0-208.x86_64

--> Processing Dependency: fping for package: ocsm-4.1.0.2.0-208.x86_64

--> Finished Dependency Resolution

Error: Package: ocsm-4.1.0.2.0-208.x86_64 (/ocsm-update)

           Requires: freetype = 2.8-12.el7

           Installed: freetype-2.4.11-15.el7.x86_64 (@ol7_latest)

               freetype = 2.4.11-15.el7

           Available: freetype-2.4.11-9.el7.i686 (ol7_latest)

               freetype = 2.4.11-9.el7

           Available: freetype-2.4.11-10.el7_1.1.i686 (ol7_latest)

               freetype = 2.4.11-10.el7_1.1

           Available: freetype-2.4.11-11.el7.i686 (ol7_latest)

               freetype = 2.4.11-11.el7

           Available: freetype-2.4.11-12.el7.i686 (ol7_latest)

               freetype = 2.4.11-12.el7

Error: Package: ocsm-4.1.0.2.0-208.x86_64 (/ocsm-update)

           Requires: fping

   You could try using --skip-broken to work around the problem

 You could try running: rpm -Va --nofiles --nodigest

Installation finished with: 1.

Aborting update.
RETURNCODE=1

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Cause
Solution


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.