My Oracle Support Banner

ACSLS 8.5.1 install.sh error pg_ctl: command not found (Doc ID 2680303.1)

Last updated on JUNE 18, 2020

Applies to:

Sun StorageTek Auto Cartridge Sys Lib SW (ACSLS) - Version 8.5.1 and later
Linux x86-64
ACSLS 8.5.1 install.sh script fails with message pg_ctl not found

Symptoms

 ACSLS 8.5.1 installation fails during execution of the $ACS_HOME/install/install.sh script with messages:

 ...
 Installing the ACSLS Database....
    Which file system will be used to store database backups? [/export/backup]?
    Backup directory: /export/backup :. Is this correct? (y or n): y

    Back up directory is: /export/backup
 ./start_acsdb.sh: line 68: pg_ctl: command not found
 ./start_acsdb.sh: line 73: pg_ctl: command not found
 ERROR: Invalid PostgreSQL version, is: , should be 10.5, exiting ...
    Error while starting the database server
 install.sh 2208: Error: ACSLS database installation failed.   Exiting.
 Please review the /tmp/install.log.

Changes


 ACSLS 8.5.1 uses postgreSQL 10.5 installed in the /opt/oracle/postgresql-10 directory.

 ACSLS 8.5.1 also installs SELinux modules to support SELinux enabled mode.
 

 The above error occurred despite the presence of the correct version of postgresql (postgreSQL 10.5), and the presence of pg_ctl in the correct directory (/opt/oracle/postgresql-10/bin).  
 Also, SELinux was enabled, and set to enforcing, and the correct ACSLS SELinux modules were installed.
 

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Changes
Cause
Solution


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.