My Oracle Support Banner

New installs of Ops Center 12.4 on Solaris 11.4 SRU 4+ expire their certificates after 2 years (Doc ID 2790192.1)

Last updated on SEPTEMBER 19, 2022

Applies to:

Enterprise Manager Ops Center - Version 12.4.0 and later
Information in this document applies to any platform.

Symptoms

The initial symptom for this problem is a failure to access the Ops Center 12.4 BUI.  It will appear to be down, and a restart of the EC/PC will not resolve the problem.

Research indicates that the HTTP process started by Ops Center is not listening on port 9443:

 

Changes

The security guide describes how to replace certificates in the Ops Center environment.  However, the customer in this case did not perform any of these steps.

https://docs.oracle.com/cd/ops-center-12.4/doc.1240/f17675/toc.htm

We have determined that the version of cacao on the Solaris OS level caused this problem.  The team that provides this cacao package enhanced the security profile of the certificates it generates.  While this is an excellent security practice, it introduced a bug into the Ops Center application.

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Changes
Cause
Solution
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.