emctl start oms Failed With 'WebTier Could Not Be Started' and ohs1.log reports 'apr_socket_connect call failed' (Doc ID 1500348.1)

Last updated on NOVEMBER 28, 2015

Applies to:

Enterprise Manager Base Platform - Version 11.1.0.1 and later
Information in this document applies to any platform.

Symptoms

OMS fails to start with the following error:

$OMS_HOME/bin>/emctl start oms

Starting WebTier...
WebTier Could Not Be Started
Error Occurred: WebTier Could Not Be Started
Please check /app/oracle/product/gc_inst/em/EMGC_OMS1/sysman/log/emctl.log for error details

$EM_INSTANCE_BASE/gc_inst/em/EMGC_OMS1/sysman/log/ohs1.log reports the following error:

[OHS] [ERROR:32] [OHS-9999] [mod_weblogic.c] [host_id: gridserv] [host_addr: IPaddress] [tid: 1800] [user: oracle] [ecid: 0000022rhC31VcAsF^n3Dw01YW3m000005] [rid: 0] [VirtualHost: gridserv.co.palm-beach.fl.us:0]  ap_proxy: trying GET /em/upload at backend host 'IPaddress/7202; got exception 'NO_RESOURCES: [os error=79,  line 1787 of ../nsapi/URL.cpp]: apr_socket_connect call failed '

And
$EM_INSTANCE_BASE/gc_inst/em/EMGC_OMS1/sysman/log/mod_wl_ohs.log reports the following error:

<253626141350670913170> *******Exception type [NO_RESOURCES] (apr_socket_connect call failed ) raised at line 1787 of ../nsapi/URL.cpp

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms