FMW Control WebCenter Domain is Missing the 'Application Deployment' Option When Connected as 'Deployer' User (Doc ID 1536814.1)

Last updated on DECEMBER 17, 2015

Applies to:

Oracle WebCenter Portal - Version 11.1.1.5.0 and later
Enterprise Manager for Fusion Middleware - Version 11.1.1.7.0 to 11.1.1.7.0
Information in this document applies to any platform.

Symptoms

This issue occurs when deploying custom WebCenter Portal applications using Fusion Middleware Control (e.g. http://<hostname>:7001/em). 

How To Reproduce:

  1. Create a user with 'Deployer' and 'Operators' groups assigned.
    This 'Deployment user' does not have the 'Administrator' group assigned.
  2. Login to the Fusion Middleware Control (Enterprise Manager) as the 'weblogic' user, you can deploy applications successfully.
    These are the steps to deploy the application when logged on as the 'weblogic' user:
    1. Navigate to <Farm name> -> Weblogic Domain Name.
    2. Right click on the domain name -> The menu has a number of options. Use the 'Application Deployment' option from this menu to deploy the application. 
     
  3. However, if you logon to Fusion Middleware Control as this 'Deployment' user with the 'Deployer' and 'Operators' groups assigned, the 'Application Deployment' option is missing from this menu.
    Therefore cannot use this user to deploy applications.

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms