E1: WAS: Screen Does Not Refresh During Processing on HTML Client in Any Application (Doc ID 1522431.1)

Last updated on MAY 30, 2017

Applies to:

JD Edwards EnterpriseOne Tools - Version 8.98 to 9.1 [Release 8.98 to 9.1]
Information in this document applies to any platform.
***Checked for relevance on 30-JUN-2014***

Symptoms

If any E1 application runs longer then a minute or long enough to produce "Gears" gif while processing (due to long running process), the screen simply remains on the first page as if nothing is happening and does not change the screen to "gears" screen.  However, if the user clicks on the opened application again, it shifts the screen. The problem it’s causing is that the end user remains on the first screen and it looks like nothing is happening although E1 is processing.

The issue only occurs in Websphere 7 and not in Websphere versions 6, 8.5 or in Oracle Weblogic server.  It also occurs with any supported browser ( Internet Explorer / Firebox / Chrome).

The browser from the HTML/Web client sends an HTTP request to the E1 JAS Server (installed with Websphere 7) and the request then triggers the long running database activity (longer than 1 minute) on E1 JAS server.  Before the database activity is completed, WAS7 resends the same HTTP request exactly one minute after, which causes the incorrect state of communication process between browser client and E1 JAS server:

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms