Secure Enterprise Search Doesn't Return Any Results or Returns Inconsistent Results within WebCenter Portal (Doc ID 1074086.1)

Last updated on MARCH 08, 2017

Applies to:

Oracle WebCenter Portal - Version 11.1.1.2.0 to 11.1.1.7.1 [Release 11g]
Information in this document applies to any platform.

Symptoms

Secure Enterprise Search (indexing SharePoint) doesn't return any Results within WebCenter Spaces.

In some cases repeating the exact same search a few minutes later it might return some results but this is not always the case.


Steps:

The issue can be reproduced with the following steps:

  1. Install and configure Oracle SES with an identity plug-in to an Identity Management system.

  2. Install and Configure WebCenter Spaces with an external LDAP (this can be different LDAP from the one configured with SES identity plug-in).

  3. Configure WebCenter with Oracle SES.

  4. Be sure WebCenter's user base matches that in Oracle SES.

  5. From here there are 2 possible scenarios:

    Scenario 1:

    • A user types some text in the search box and clicks on the Search button.
      The search is expected to return results but the search result is empty.

    • Any search done by the user brings the search results empty.


    Scenario 2:

    • A user types some text in the search box and clicks on the Search button.
      The search is expected to return results but the search result is empty.

    • The user repeats the exact same search a few minutes later and this time the search returns results as expected.

 

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms