JDeveloper/ADF 11.1.1.6, 11.1.1.7, 11.1.1.9.0 and WebLogic Server 10.3.6 Setup

(Doc ID 1435962.1)

Last updated on DECEMBER 05, 2016

Applies to:

Oracle JDeveloper - Version 11.1.1.6.0 to 11.1.1.9.0 [Release Oracle11g]
Information in this document applies to any platform.
Many users preferred method to install the ADF runtime libraries on WebLogic Server was to use the same JDeveloper installer they used to install JDeveloper IDE. Also many users install JDeveloper in the same Middleware home as the other Fusion Middleware products, like WebLogic Server, SOA, and so on.

(NOTE: As a general recommendation, you should install JDeveloper into it's own directory and not on top of an existing Middleware home as WebLogic Server and/or other products.)

The base rule was to follow the Certification Matrix for Application Servers and match versions with WebLogic Server:

- JDeveloper/ADF Runtime 11.1.1.1.0 with WebLogic Server 10.3.1
- JDeveloper/ADF Runtime 11.1.1.2.0 with WebLogic Server 10.3.2
- JDeveloper/ADF Runtime 11.1.1.3.0 with WebLogic Server 10.3.3
- JDeveloper/ADF Runtime 11.1.1.4.0 with WebLogic Server 10.3.4
- JDeveloper/ADF Runtime 11.1.1.5.0 with WebLogic Server 10.3.5

So far, this was possible through all the 11g installers for JDeveloper, until 11.1.1.6 release. With the 11.1.1.6 and 11.1.1.7 releases, ADF can run on two different versions of WebLogic Server: 10.3.5 and 10.3.6. This presents us a constraint with the JDeveloper installer.

With the JDeveloper 11.1.1.6, 11.1.1.7 installer you can't:

- Install ADF 11.1.1.6, 11.1.1.7 runtime on top of WebLogic Server 10.3.6.
- Install JDeveloper 11.1.1.6, 11.1.1.7 in the same Middleware home as WebLogic Server 10.3.6.

If you try to do it, you will receive an error message. See below.

JDeveloper/ADF Runtime 11.1.1.9.0 is only certified with WebLogic Server 10.3.6

Symptoms

When trying to install JDeveloper/ADF 11.1.1.6, 11.1.1.7 on top of WebLogic Server 10.3.6 you get the error message:

The product maintenance level of the current installer (WebLogic Server:10.3.5.0) is not compatible with the maintenance level of the product installed on your system(WebLogic Server:10.3.6.0). Please obtain a compatible installer or perform maintenance on your current system to achieve the desired level.

Note that JDeveloper 11.1.1.9.0 is bundled with WebLogic Server 10.3.6, so you should not see this error. JDeveloper 11.1.1.9.0 is not certified to work with WebLogic Server 10.3.5.

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms