OPSS - Getting "JPS-10702: the datasource jdbc/OPSSDS is not found" while running reassociateSecurityStore

(Doc ID 1449754.1)

Last updated on MARCH 20, 2017

Applies to:

Oracle Platform Security for Java - Version and later
Information in this document applies to any platform.


Upgraded the FMW from to and reassociate the security store (policystore,credstore) to db store

Error : “JPS-10702: the datasource jdbc/OPSSDS is not found”
reassociateSecurityStore(domain="DefaultDomain",  datasourcename="jdbc/OPSSDS",servertype="DB_ORACLE",  jpsroot="cn=jpsTestNode")

JPS-10702 during policy migration



Oracle® Fusion Middleware Application Security Guide
11g Release 1 (11.1.1)

Part Number E10043-08

8.5 Reassociating the OPSS Security Store


Reassociating the OPSS security store consists in relocating the policy, credential, and key stores from one repository to another one. The source can be file-, LDAP-, or DB-based; the target can be LDAP- or DB-based. The only type of LDAP target supported is Oracle Internet Directory; the only type of DB target supported is DB_ORACLE.




Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms