My Oracle Support Banner

Forms/Reports 10gR2 (10.1.2) - Premier Support Ended (Doc ID 1506026.1)

Last updated on DECEMBER 20, 2019

Applies to:

Oracle Forms - Version 10.1.2.0.2 to 10.1.2.3.0 [Release Oracle10g to 10.1.2.3]
Oracle Reports Developer - Version 10.1.2.0.2 to 10.1.2.3 [Release Oracle10g to 10gr2]
Information in this document applies to any platform.

Details

Oracle Forms/Reports 10gR2 (10.1.2.x) Premier Support Ended (Desupported)

This note applies to Oracle Developer Suite and Oracle Application Server 10gR2 (10.1.2.0.2).  It does not apply to users of Oracle EBusiness Suite or other business suite products (e.g. Financials, Retail, Clinicals, etc).  Refer to the Lifetime Support documents for information about your specific product line.  More specific details about this desupport are covered in the Fusion Middleware Lifetime Support document.

Oracle Forms/Reports 10gR2 (includes Application Server and Developer Suite 10.1.2.0.2) was released in late 2005.  As of December 2011, Premier Support for this product version has ended.  With Premier Support ending, this product is no longer entitled to the following:

• New updates, fixes, security alerts, data fixes, and critical patch updates
• New tax, legal, and regulatory updates
• New upgrade scripts
• Certification with new third-party products/versions
• Certification with new Oracle products

In short, this means that Oracle Support can no longer file product defect reports (bugs) for this product version, nor can Oracle Support provide patches for existing bugs unless they already exist.   This also means that if a particular bug fix is not available for your platform, one cannot be requested. 

Please refer to your Support Contract to determine your specific entitlement.  Some exceptions may apply to your account.  Please do not ask Oracle Support for information about your account or entitlements as that information is not available to them.  For questions about your account and/or Support contract, please contact your Account Manager or Sales Representative.

 

Actions

Recommendations

Customers still using version 10.1.2 or older should consider upgrading to a currently supported version as soon as possible.  Choosing to not upgrade may interfere with Support's ability to assist you if needed.  If you are unable to upgrade at this time and must remain on version 10.1.2, it is recommended that you install a minimum of the following patches.  These patches and steps will help to ensure that your system is as stable and secure as possible. Follow them in the order they are listed.

For more detailed information regarding the patching of a version 10.1.2.0.2 environment and its related components, refer to <Note:415222.1>

 Before installing any patches, be sure to create a system backup and as a minimum, create a backup of your installation.  Also, be sure to review the documentation included with every patch.

1.  If you are not already running 10.1.2.3, install <Patch:5983622>

2.  Follow the instructions in <Note:1058514.1>

3.  If you have not already done so, install the latest version of OPatch.  <Patch:6880880>.   For the "Release" field, be sure to choose 10.1.0.0.0

4.  For Unix platforms, install <Patch:7121788>

If you are having problems with an Oracle Forms or Reports application and believe you will need assistance from Oracle Support, please be sure to first complete the steps noted above and install the following additional patches then retest.  Again, be sure to review each patches' documentation before installing.

5.  Install Forms Bundle <Patch:9593176> (see <Note:1188127.1> and review the patch Readme)

6. Ensure you install OUI <Patch 6640838 > as described in <Note 1301320.1> to ensure this is installed correctly. This is mentioned in <Note 1188127.1> in the section entitled Post Installation Concerns/Issues.

7.  Install Forms <Patch 14614795>.

Note: Some customers may wish to apply <Patch 18152215>  instead of 14614795 to update manifest entries in the Oracle supplied jar files. Although Premier Support for 10gR2 had ended by the time later JRE versions required specific manifest entries, Oracle did provide this final 10gR2 courtesy patch for the issue. For a thorough discussion of JRE/Manifest issues see <Note 1594575.1> JRE Security Warning - UNKNOWN Publisher Blocked in Future Releases - JAR File Manifest Missing Permissions Attribute.

8.  For Oracle Reports, refer to <Note:1162562.1>

At this point you will have installed most of the patches which are available and supported for use with stand-alone Forms/Reports 10gR2.  See <Note:415222.1> for a complete list of specific component level patches.  Patches released after the ones mentioned above are intended for EBusiness Suite only and will not be supported for installation into non-EBusiness environments.  Installing such patches is not recommended.

Note:  In some cases the Oct 2011 CPU patch may resolve some JRE 1.7 issues although 1.7 was never supported in non-EBusiness environments. See <Note 1576591.1 >.  For this reason and for security considerations you should consider installing the OCT 2011 CPU.   See <Note:1346104.1> for details.

 

Contacts

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Details
 Oracle Forms/Reports 10gR2 (10.1.2.x) Premier Support Ended (Desupported)
Actions
 Recommendations
Contacts
References

My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.