ODSEE 11x DSCC can manage 6.x, 7.x and 11.x DS instances; 6.3.1 instances will require command line registration

(Doc ID 1541174.1)

Last updated on OCTOBER 11, 2016

Applies to:

Oracle Directory Server Enterprise Edition - Version 6.3 to 11.1.1.5.2 [Release 6.0 to 11gR1]
Information in this document applies to any platform.

Symptoms

When attempting the registration of a 6.3x Directory Server or Directory Proxy Server instance to an 11g DSCC using the web interface, an error message  is presented.

Starting server ds-server.example.com:1389. Server Logs:
Directory Server instance '/export/servers/dscc_test' is a 6.x instance.
You must run 'dsadm upgrade /export/servers/dscc_test' before using it with DSEE 7 commands.
   Error executing the operation. The error code is 167.

This error is thrown upon attempt to restart the DS instance from the create or register process.  It is indicating a failure and that the customer should upgrade the instance first.  This error message is seen when attempting to register or create a 6.3x DS or DPS instance through the DSCC.. This is not necessary.  The 11g DSCC does support managing all instances of DS back to 6.3x. The discussion of this is presented in the migration guide, here:

  http://docs.oracle.com/cd/E20295_01/html/821-1219/upgradedsdpsdscc.html#scrolltoc

The specific reference being "Using DSCC 11g Release 1 (11.1.1.5.0), you can access version 6, 7.0, and 11g Release 1 (11.1.1.5.0) instances."  
This is true for 11g releases in general.

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms