Missing Key In Reports Server With OID Association in HA Configuration (Doc ID 1564789.1)

Last updated on JULY 02, 2016

Applies to:

Oracle Reports Developer - Version 11.1.1.2.0 and later
Information in this document applies to any platform.

Symptoms


When attempting to associate two nodes in clusters with OID (Oracle Internet Directory), the following error occurs on only ONE of the 2 nodes when trying to re-start Reports Server:

REP-50125 : oracle.security.jps.service.credstore.CredStoreException: Could not find the key specified

 

Checking Credentials under domain one can see that the OID credentials for second node was not created.

This issue only happens when the second node is a remote node. If the second instance is running on the same node1, then this issue will not happen and both OID credentials will be created without an issue.



STEPS

The issue can be reproduced at will with the following steps:
1. Follow instructions in Chapter 14 and 16 in “Publishing Reports to the Web with Oracle Reports Services” : 
  EM Console -> Reports Server -> Reports Menu -> Administration -> Reports OID Association.
2. Do the above on each node
3. Try to start the reports servers


WHAT IS WORKING

Only one node recognizes the OID association.

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms