Installing WebTier 11.1.1.7 on SUSE 64bit, OPMN Fails to Start OHS With the Error "Failed to start component ohs1" (Doc ID 1600191.1)

Last updated on NOVEMBER 04, 2016

Applies to:

Oracle HTTP Server - Version 11.1.1.7.0 to 11.1.1.7.0 [Release Oracle11g]
SUSE \ UnitedLinux x86-64

Symptoms

The 11g webtier installation successfully completed, but during configuration, while starting ohs component, following errors will be seen in installation log.

2013-09-10T17:26:41.307-03:00] [as] [NOTIFICATION] [] [oracle.as.install.config] [tid: 29] [ecid: 0000K49ZSKa7q2S6yFicMG1IBrmX00000K,0] *************** Trying to Reload OPMN **************
[2013-09-10T17:26:41.308-03:00] [as] [NOTIFICATION] [] [oracle.as.install.config] [tid: 29] [ecid: 0000K49ZSKa7q2S6yFicMG1IBrmX00000K,0] *************** Executing Command **************
[2013-09-10T17:26:41.308-03:00] [as] [NOTIFICATION] [] [oracle.as.install.config] [tid: 29] [ecid: 0000K49ZSKa7q2S6yFicMG1IBrmX00000K,0] /products/oracle/11.1.1/ohs/ohs/instances/ohs1/bin/opmnctl reload
[2013-09-10T17:26:41.308-03:00] [as] [NOTIFICATION] [] [oracle.as.install.config] [tid: 29] [ecid: 0000K49ZSKa7q2S6yFicMG1IBrmX00000K,0] ***************************************************
[2013-09-10T17:26:47.014-03:00] [as] [WARNING] [] [oracle.as.config] [tid: 29] [ecid: 0000K49ZSKa7q2S6yFicMG1IBrmX00000K,0] Failed to start component ohs1[[
oracle.as.config.ProvisionException: HTTP status code = 204 : 0 of 1 processes started.
at oracle.as.config.impl.OracleASComponentBaseImpl.manageProcess(OracleASComponentBaseImpl.java:943)
at oracle.as.config.impl.OracleASComponentBaseImpl.start(OracleASComponentBaseImpl.java:1062)
at oracle.as.install.webtiercd.webtierconfig.util.CreateComponent.createOHSComponentWrapper(CreateComponent.java:152)
at oracle.as.install.webtiercd.webtierconfig.util.CreateComponent.createStandaloneOHSComponent(CreateComponent.java:81)
at oracle.as.install.webtiercd.webtierconfig.actions.WebtierConfigurationAction.configureOHSStandalone(WebtierConfigurationAction.java:545)
at oracle.as.install.webtiercd.webtierconfig.actions.WebtierConfigurationAction.configureStandalone(WebtierConfigurationAction.java:443)
at oracle.as.install.webtiercd.webtierconfig.actions.WebtierConfigurationAction.doExecute(WebtierConfigurationAction.java:174)
at oracle.as.install.engine.modules.configuration.client.ConfigAction.execute(ConfigAction.java:375)
at oracle.as.install.engine.modules.configuration.action.TaskPerformer.run(TaskPerformer.java:88)
at oracle.as.install.engine.modules.configuration.action.TaskPerformer.startConfigAction(TaskPerformer.java:105)
at oracle.as.install.engine.modules.configuration.action.ActionRequest.perform(ActionRequest.java:15)
at oracle.as.install.engine.modules.configuration.action.RequestQueue.perform(RequestQueue.java:96)
at oracle.as.install.engine.modules.configuration.standard.StandardConfigActionManager.start(StandardConfigActionManager.java:186)
at oracle.as.install.engine.modules.configuration.boot.ConfigurationExtension.kickstart(ConfigurationExtension.java:81)
at oracle.as.install.engine.modules.configuration.ConfigurationModule.run(ConfigurationModule.java:86)
at java.lang.Thread.run(Thread.java:662)

 And following errors will be seen in console~OHS~1.log.

--------
13/09/10 17:26:43 Start process
--------
/products/oracle/11.1.1/ohs/ohs/ohs/bin/apachectl startssl: execing httpd

--------
13/09/10 17:26:45 Start process
--------
/products/oracle/11.1.1/ohs/ohs/ohs/bin/apachectl startssl: execing httpd

Even manually starting OHS fails.

Changes

 It is a new installation of webtier. Issue will be seen during configuration phase.

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms