Login fails but credentials are correct (Doc ID 1626449.1)

Last updated on NOVEMBER 03, 2016

Applies to:

Oracle WebCenter Sites - Version 11.1.1.8.0 and later
Information in this document applies to any platform.

Symptoms

Logging into Contributor UI with user having valid password and sufficient credentials, the user is authenticated but then redirects to an error page. In the sites.log the following error appears:

Feb 8, 2014 12:26:41 PM com.sun.jersey.server.impl.application.WebApplicationImpl mapMappableContainerException
SEVERE: The RuntimeException could not be mapped to a response, re-throwing to the HTTP container
java.lang.NullPointerException
at com.fatwire.util.ImageUtil.encodeBase64(ImageUtil.java:279)
at com.openmarket.xcelerate.user.UserManager.buildUserAttributes(UserManager.java:273)
at com.openmarket.xcelerate.user.UserManager.buildUser(UserManager.java:292)
at com.openmarket.xcelerate.user.UserManager.getUsers(UserManager.java:530)
at com.fatwire.assetapi.site.SiteManagerImpl.read(SiteManagerImpl.java:227)
at com.fatwire.rest.util.WEMApplicationUtil._updateApplicationAccessRoles(WEMApplicationUtil.java:660)
at com.fatwire.rest.util.WEMApplicationUtil.getApplication(WEMApplicationUtil.java:267)
at com.fatwire.rest.service.impl.LocalApplicationServiceImpl.getApplication(LocalApplicationServiceImpl.java:130)
at com.fatwire.rest.resources.ApplicationResource.getApplication(ApplicationResource.java:50)


Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms