Unable to login due to java.io.UnsupportedEncodingException from fatwire/wem/sso/ssoLogin.jsp after upgrade (Doc ID 1983525.1)

Last updated on JULY 07, 2017

Applies to:

Oracle WebCenter Sites - Version 11.1.1.6.0 to 11.1.1.8.0 [Release FatWire]
Information in this document applies to any platform.

Symptoms

Unable to login after upgrade; see the following in sites.log:

"

[2015-02-13 10:21:56,763 CST] [ERROR] [.kernel.Default (self-tuning)'] [fatwire.security.common.EncodedParameterMap] decode failure: java.lang.NullPointerException
[2015-02-13 10:21:56,764 CST] [ERROR] [.kernel.Default (self-tuning)'] [fatwire.logging.cs.request] Exception including resource /jsp/cs_deployed/fatwire/wem/sso/ssoLogin.jsp
java.io.UnsupportedEncodingException
    at com.fatwire.security.common.EncodedParameterMap.decode(EncodedParameterMap.java:105)
    at jsp_servlet._jsp._cs_deployed._fatwire._wem._sso.__ssologin._jspService(__ssologin.java:125)

"

Changes

The environment was just upgraded from 11.1.1.6.x to 11.1.1.8.0.

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms