My Oracle Support Banner

Calling A Page Via SystemEvents Not Working (Blocked By Redirection) (Doc ID 2117962.1)

Last updated on OCTOBER 03, 2017

Applies to:

Oracle WebCenter Sites - Version 11.1.1.8.0 and later
Information in this document applies to any platform.

Symptoms

To call a page periodically via System Events, I add a SystemEvents table entry with following parameters:

But it does not work well, it seems not to be fired anyway.

Then, I checked fatwire.logging.cs.event=DEBUG log and access log of the application server.
They indicated that the event actually fired, but it returned with 301 status (not 200).

sites.log (cs.event=DEBUG)

[2016-03-17 01:23:53,883 UTC] [DEBUG] [temBasedClusteredEventExecutor] [fatwire.logging.cs.event] Lock obtained successfully for /home/fm1111/product/WebCenterSites/Shared/clustersync/event/lock/THTest.nextruntime
[2016-03-17 01:23:53,883 UTC] [DEBUG] [temBasedClusteredEventExecutor] [fatwire.logging.cs.event] About to run event THTest
[2016-03-17 01:23:53,883 UTC] [DEBUG] [temBasedClusteredEventExecutor] [fatwire.logging.cs.event] RequestEventItem about to invoke http://yemen.jp.oracle.com:8080/cs/ContentServer?thapp=event&pagename=FirstSiteII%2FTHBlankTmpl
[2016-03-17 01:23:53,891 UTC] [DEBUG] [temBasedClusteredEventExecutor] [fatwire.logging.cs.event] Invoking http://yemen.jp.oracle.com:8080/cs/ContentServer?thapp=event&pagename=FirstSiteII%2FTHBlankTmpl returned

access log

10.185.155.57 - - [17/Mar/2016:01:17:30 +0000] "POST /cs/ContentServer?pagename=FirstSiteII%2FTHBlankTmpl HTTP/1.1" 301 5

 

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Cause
Solution
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.