Error “Unable to run the service and GET_RELATED_CONTENT getRelatedTypeInfo function” (Doc ID 2146392.1)

Last updated on JUNE 13, 2017

Applies to:

Oracle WebCenter Content - Version 11.1.1.8.0 and later
Information in this document applies to any platform.

Goal

After activating component "RELATEDCONTENT" in UCM, 2 tables were created in the UCM Schema in Database:
RELATEDCONTENT (empty) and RELATEDTYPES (4 occurrences).

After the activation of component, an error is recorded while using AutoVue. Just clicking on "View in Autoview" generated the error in Content Server Log:

The table "RELATEDTYPES" did not contain the type '5': The following row was manually inserted in the table according to what was registered during the activation of component "RELATEDCONTENT" in the 11.1.1.6 version of UCM:

table RELATEDTYPES
==================
DLINKTYPEID = 5
DLINKCLASSID = PC
DLINKTYPENAME = MarkupAutovue
DLYNKTYPEDESTNAME = MarkupAutovue
DLYNKTYPESCHECKINDESTNAME = MarkupAutovue
DLINKTYPESCHECKINDESTNAME2 = MarkupAutovue
DISLINKBYNAME = 0
DISSYSTEMLINK = 0

After this addition to the table, AutoVue calls did not produce the error message when using it.
Please confirm that enabling RELATEDCONTENT component and adding the row DLINKTYPEID = 5 is good method to avoid having error with AutoVue and that the component is related to AutoVue?

Solution

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms