Tuxedo 12.1.3 Base Product Installation Failing With "Unsupported Major.minor Version 51.0 Occurred" Error (Doc ID 2164653.1)

Last updated on JANUARY 20, 2017

Applies to:

Oracle Tuxedo - Version 12.1.3 and later
Information in this document applies to any platform.

Symptoms

Scenario1: 12.1.3 version of Tuxedo GA Installer (that is to say, the generally available Tuxedo 12.1.3 base installer downloaded from Oracle) for Red Hat Enterprise 6 Linux x86-64

Trying to install Tuxedo 12.1.3 GA in silent mode as follows: "./runInstaller -responseFile /myRespFiles/tuxres.rsp -silent -force"

The following error occurs:

Exception java.lang.UnsupportedClassVersionError: OiJarResourceLoader : Unsupported major.minor version 51.0 occurred..
java.lang.UnsupportedClassVersionError: OiJarResourceLoader : Unsupported major.minor version 51.0
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClassCond(Unknown Source)
at java.lang.ClassLoader.defineClass(Unknown Source)
at java.lang.ClassLoader.defineClass(Unknown Source)
at oracle.sysman.oii.oiix.OiixJarClassLoader.loadClassCurrent(OiixJarClassLoader.java:584)
at oracle.sysman.oii.oiix.OiixJarClassLoader.loadClass(OiixJarClassLoader.java:646)
at oracle.sysman.oii.oiix.OiixJarClassLoader.loadClass(OiixJarClassLoader.java:731)
at oracle.sysman.oii.oiix.OiixJarResourceBundle.extractBundle(OiixJarResourceBundle.java:357)
at oracle.sysman.oii.oiis.OiisLibraryLoader.<init>(OiisLibraryLoader.java:119)
at oracle.sysman.oii.oiis.OiisQueryLibLoader.<init>(OiisQueryLibLoader.java:42)
at oracle.sysman.oii.oiic.OiicPullSession.getLibLoader(OiicPullSession.java:4529)
at oracle.sysman.oii.oiic.OiicInstallSession.getLibLoader(OiicInstallSession.java:3680)
at oracle.sysman.oii.oiic.OiicPullSession.getQueryLibLoader(OiicPullSession.java:4590)
at oracle.sysman.oii.oiis.OiisCompContext.doQuery(OiisCompContext.java:2381)
at Components.Tuxedo.v12_1_3_0_0.CompContext.getCalculatedValueObject_PRE_REQUISITE(Unknown Source)
at Components.Tuxedo.v12_1_3_0_0.CompContext.getCalculatedValueObject(Unknown Source)
at oracle.sysman.oii.oiis.OiisCompContext.getCalculatedValue(OiisCompContext.java:653)
at oracle.sysman.oii.oiis.OiisPreRequisiteVar.getCalculatedValue(OiisPreRequisiteVar.

 

Scenario2: Following "PeopleTools 8.55 Installation for DB2 for z/OS" instructions Tuxedo 12.1.3 is installed successfully

Then Tuxedo 12.1.3 rolling patch RP090 is attempted with "opatch apply 25343463.zip" but get the same error as above.

Changes

 

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms