How To Force ODI 12.1.3 To Use TLS v1.1 (and TLS v1.2) For Connecting Web Services Which are Enabled as TLS V1.1 Only (Doc ID 2233230.1)

Last updated on MAY 12, 2017

Applies to:

Oracle Data Integrator - Version 12.1.3.0.0 and later
Information in this document applies to any platform.

Goal

ODI 12.1.3 is certified with JDK 1.7.0_XX and JDK 1.7.0_XX by default supports only TLS v1.0.

Since TLS v1.1 and TLS V1.2 are available and more and more web service providers only allow to use these newer versions of TLS to connect to their web services due to security reason, the purpose of this note to show users how to configure ODI 12.1.3 Java properties so that it will support TLS v 1.1 and v 1.2 (if needed).
 

Solution

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms