My Oracle Support Banner

Error "The domain to be read must be a directory containing a valid domain of version 9.0.0.0.0 or up" While Starting Standalone Oracle HTTP Server (Doc ID 2250882.1)

Last updated on AUGUST 23, 2022

Applies to:

Oracle HTTP Server - Version 12.2.1.2.0 and later
Information in this document applies to any platform.

Symptoms

When starting standalone 12.2.1.2 Oracle Http Server, it fails with below errors.

Steps to Reproduce:
1. Install standalone OHS

2. Configure OHS and create ohs1 component.

3. Start Nodemanager and ohs1 to confirm everything is working.

4. Update config.xml file under DOMAIN_HOME/config directory and added line:
<machine>m1</machine>
after first line
***This is basically to reproduce the issue by corrupting config.xml

5. Now start Nodemanager

6. Start OHS and receive the error:

 

Note: The problem/error reproduces only in standalone OHS and does not reproduce in collocated OHS

Changes

 

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Changes
Cause
Solution
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.