WSMERROR-00015 During Upgrading RMS To V 16.0.1 (Doc ID 2289605.1)

Last updated on JULY 26, 2017

Applies to:

Oracle Web Services Manager - Version 12.2.1.0.0 and later
Oracle Retail Merchandising System - Version 16.0 and later
Information in this document applies to any platform.

Goal

Upgrading an existing Fusion Middleware infrastructure from 12.2.1.0 to 12.2.1.2.0
After installing 12.2.1.0, while installing RMS (Oracle Retail Merchandising System), the following note was used:

NOTE: 2222362.1 - RMS 16.0 - Unable to Create MDS-Customportalids Datasource Using EM

which calls for the removal of the mds-owsm data source form the environment.

Now, during the Fusion Middleware upgrade to 12.2.1.2.0 using

/ua -readiness

an error occurs:

[WSM] [INCIDENT_ERROR] [] [upgrade.WSM.WSMPLUGIN] [tid: 107] [ecid: a8564328-d528-4fb1-8cbb-3dad7a238e0a-00000002,0] [[
oracle.ias.update.exception.UpgradeException: WSMERROR-00015: Failed to read the Oracle WSM datasource connection details.
at oracle.wsm.lifecycle.upgrade.impl.WSMUpgradePlugin.initializePluginData(WSMUpgradePlugin.java:386)
at oracle.wsm.lifecycle.upgrade.impl.WSMUpgradePlugin.readiness(WSMUpgradePlugin.java:150)

This is due to the data source being removed earlier.

How can this error be overcome sot the upgrade can be completed?

Solution

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms