My Oracle Support Banner

ODI Upgrade From 12.1.3 To 12.2.1.2.6 Failing With "ORA-01408: such column list already indexed" (Doc ID 2306208.1)

Last updated on OCTOBER 04, 2017

Applies to:

Oracle Data Integrator - Version 12.2.1.2.6 and later
Information in this document applies to any platform.

Symptoms

When attempting to run the Upgrade Assistant (UA) to upgrade Oracle Data Integrator (ODI) 12.1.3 to 12.2.1.2.6, the following error occurs and the upgrade cannot continue:

[2017-08-02T16:58:04.056-04:00] [ODI] [INCIDENT_ERROR] [ODIUPG-00011] [upgrade.ODI.ODI1] [tid: 22] [ecid: 1a8e541c-dcba-46a9-bbd8-2c02aceaff2e-00000002,0] Unknown error happened.
[2017-08-02T16:58:04.056-04:00] [ODI] [INCIDENT_ERROR] [] [upgrade.ODI.ODI1] [tid: 22] [ecid: 1a8e541c-dcba-46a9-bbd8-2c02aceaff2e-00000002,0] Cause: Unknown error happened.
[2017-08-02T16:58:04.056-04:00] [ODI] [INCIDENT_ERROR] [] [upgrade.ODI.ODI1] [tid: 22] [ecid: 1a8e541c-dcba-46a9-bbd8-2c02aceaff2e-00000002,0] Action: Restore Work Repository from Backup and try to upgrade again.
[2017-08-02T16:58:04.056-04:00] [ODI] [INCIDENT_ERROR] [] [upgrade.ODI.ODI1] [tid: 22] [ecid: 1a8e541c-dcba-46a9-bbd8-2c02aceaff2e-00000002,0] [[
oracle.odi.setup.RepositorySetupException: com.sunopsis.repository.manager.upgrade.RepositoryUpgradeException: Error while executing DDL Patch E_05.01.02.03_05.01.02.04.xml
  at oracle.odi.setup.support.WorkRepositorySetupImpl$5.doAction(WorkRepositorySetupImpl.java:1138)
  at oracle.odi.core.persistence.dwgobject.DwgObjectTemplate.execute(DwgObjectTemplate.java:173)
  at oracle.odi.core.persistence.dwgobject.TransactionalDwgObjectTemplate.execute(TransactionalDwgObjectTemplate.java:41)
  at oracle.odi.setup.support.WorkRepositorySetupImpl.upgradeWorkRepository(WorkRepositorySetupImpl.java:962)
  at oracle.odi.setup.support.WorkRepositorySetupImpl.upgradeWorkRepository(WorkRepositorySetupImpl.java:1312)
  at oracle.odi.setup.RepositoryUpgradeServiceImpl.upgradeWork(RepositoryUpgradeServiceImpl.java:163)
  at oracle.odi.setup.RepositoryUpgradeServiceImpl.upgradeRepositories(RepositoryUpgradeServiceImpl.java:614)
  at oracle.ias.update.plugin.odi.ODIPlugin.upgrade(ODIPlugin.java:428)
Caused by: com.sunopsis.repository.manager.upgrade.RepositoryUpgradeException: Error while executing DDL Patch E_05.01.02.03_05.01.02.04.xml
Caused by: java.lang.RuntimeException: Error while executing create index PAR_SB_TASK_FK on SNP_SB_TASK ( SB_NO , NNO , PAR_SCEN_TASK_NO )
Caused by: java.sql.SQLException: ORA-01408: such column list already indexed

Changes

 

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Changes
Cause
Solution
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.