My Oracle Support Banner

ORDS Installation Error for 12c Database When Using a User with SYSDBA Privileges: ORA-02097 / ORA-01031 (Doc ID 2330872.1)

Last updated on NOVEMBER 21, 2017

Applies to:

Oracle REST Data Services - Version 3.0.12 and later
Information in this document applies to any platform.

Symptoms

Trying to install ORDS version 3.0 against a 12c database. As a part of that install, another user (not SYS) with SYSDBA privileges was entered at the prompt:
Enter the username with SYSDBA privileges to verify the installation [SYS]: SOMEUSER

The remaining configuration prompts are entered:
Enter the database password for SOMEUSER:
Confirm password:
Enter 1 if you want to use PL/SQL Gateway or 2 to skip this step.
If using Oracle Application Express or migrating from mod_plsql then you must enter 1 [1]:1
Enter the database password for APEX_PUBLIC_USER:
Confirm password:

...

After completing the ORDS configuration prompts, the following error is seen:


Installing Oracle REST Data Services version 3.0.12.263.15.32
... Log file written to /app/oracle/fmw/ords/logs/ords_install_core_2017-11-14_175828_00730.log
... Verified database prerequisites
Nov 14, 2017 5:58:31 PM oracle.dbtools.installer.Installer pdbOrNonCDBProcessing
SEVERE: Error executing script: ords_alter_session_script.sql Error: ORA-02097: parameter cannot be modified because specified value is invalid
ORA-01031: insufficient privileges
ORA-06512: at line 16

The installation is being performed locally on the database server. It is not being performed remotely.

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.