"There is a problem with your environment because the Application Express files are not up-to-date!" with ORDS Hosted in Weblogic Server (WLS)

(Doc ID 2342618.1)

Last updated on DECEMBER 22, 2017

Applies to:

Oracle Application Express (formerly HTML DB) - Version 5.0.4.00 and later
Information in this document applies to any platform.

Symptoms

Note: This issue is not specific to any particular version of APEX. The versioning here is just an example.

1. Upgrade to APEX 5.1.3 from APEX 5.0.4 in a 12.1.0.2 DB.
2. ORDS 3.0.9 is hosted on Weblogic Server (WLS).
3. /i/ is the virtual directory.
4. http://machine:<wls port>/i/apex_version.txt displays the correct images version:

Application Express Version: 5.1.3

5. When attempting to access APEX (http://machine:<wls port>/ords) the following message occurs:

There is a problem with your environment because the Application Express files are not up-to-date. The files for version 5.0.4.00.12 have been loaded, but the 5.1.3.00.05 is expected.

Here is an example of the entire message:

 

Changes

 Upgraded to APEX 5.1 from APEX 5.0.

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms