My Oracle Support Banner

TLSV1.1+ Encryption Not Working Between WebLogic 12.1.3 Datasource and Oracle Database 12.1 (Doc ID 2385855.1)

Last updated on MAY 17, 2018

Applies to:

Oracle WebLogic Server - Version 12.1.3.0.0 and later
Information in this document applies to any platform.

Symptoms

Unable to get TLSV1.1+ encryption to work between a datasource configured in Oracle WebLogic (WLS) 12.1.3 and Oracle Database 12.1

When we try to limit the TLS protocol to 1.1 or 1.2 on the database side, WLS fails to connect.

Confirmed JDBC driver installed with WLS 12.1.3 is based on 12.1.0.2 and should support TLS 1.1 and 1.2 by default
Reference <Note 1970437.1> - How To Update the JDBC and UCP Drivers Bundled with WebLogic Server 10.3.6 and 12c

Tried to pass on the command line various parameters and examined the logs.

 i.e ClientHello itself doesn't get established.

Changes

 

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.