My Oracle Support Banner

Test Point "?WSDL" for Webservice in Weblogic Server Admin Console Does not Work (Doc ID 2415431.1)

Last updated on JULY 02, 2018

Applies to:

Oracle WebLogic Server - Version 12.2.1.3.0 and later
Information in this document applies to any platform.

Symptoms

Administration Port does not work when test point "?WSDL" is provided for webservice links in the Weblogic Server Admin Console.
If the Admin port is manually changed to SSL port in the URL, the webservice test client opens.

In WebLogic 12.2.1.3 version, issue of Application Test Point from console for deployments shown incorrectly as target managed server administration port was reported when SSL/Domain Wide Administration Ports are enabled and non SSL ports are disabled. Application Test Point in console should be showing SSL port of target managed server instead of administration port. When disabling the Domain Wide Administration port, this issue does not happen and the application test point shows correctly the SSL port of target server.

Issue can be seen with below domain configuration:

- Admin Server and Managed server part of Cluster or without Cluster configuration (There is no Fronted Host configuration for cluster).

- Domain wide Administration Port enabled, SSL ports enabled for Admin and Managed servers and non SSL ports disabled.

- Application deployed on Cluster (or) individual standalone managed servers.

When accessing the Test point "?WSDL" for webservice, the URL is directing to the non SSL Admin port of the Server and the page does not show. When changing manually the admin to SSL port, the page is displaying correctly.

 

Changes

 No Changes

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.